Bug 55098 - DOCUMENTATION soffice --help gives incorrect option for -show
Summary: DOCUMENTATION soffice --help gives incorrect option for -show
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other Windows (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:4.0.0
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-19 14:56 UTC by Olivier Hallot
Modified: 2012-11-26 21:05 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Hallot 2012-09-19 14:56:44 UTC
\...\soffice.exe --show "praesentation.odp" 

in windows command line does not work. The presentation does not show in presentation mode. It shows in edit mode.

This prevents using impress in kiosks, where the presentation must start in display mode, not edit mode.

Seems that soffice.exe is reaaly broken. See bug 51639 for another borked parameter.
Comment 1 Andrzej Hunt 2012-09-21 09:20:25 UTC
Hi. On Windows the correct option is "-show" (one dash). With this I couldn't reproduce any problems using 3.5 or master (3.7.0.0.alpha+) on Windows Vista or openSUSE 12.2. Could you please confirm whether using "-show" works?

Please see http://help.libreoffice.org/Impress/Showing_a_Slide_Show for documentation on this.
Comment 2 Olivier Hallot 2012-09-21 12:41:05 UTC
Thanks for looking at.

Indeed -show works in 3.5.4 under windows

However soffice --help clearly states us to use --show.

So either we fix the help screen or we fix soffice binary. But by the way, soffice.exe has many other flaws (e.g. --version).
Comment 3 Andrzej Hunt 2012-09-21 13:00:51 UTC
Renamed the bug for clarity.

I would suggest implementing --show in addition to -show for consistency with other options, rather than changing the documentation. (Similar to -version which informs you that it is deprecated.)
Comment 4 Andras Timar 2012-11-26 21:05:37 UTC
It was fixed by Caolán, 4fc8af89257436b9cad70de574a166aa11ec42f1
--show works as well as deprecated -show