Download it now!
Bug 55125 - EDITING: Crash when inserting the 65535th character
Summary: EDITING: Crash when inserting the 65535th character
Status: RESOLVED DUPLICATE of bug 60732
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.2.1 rc
Hardware: Other All
: low minor
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-19 23:19 UTC by Sascha Fichtner
Modified: 2013-02-21 20:34 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Repro .odt file. (10.26 KB, application/vnd.oasis.opendocument.text)
2012-09-19 23:19 UTC, Sascha Fichtner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sascha Fichtner 2012-09-19 23:19:35 UTC
Created attachment 67420 [details]
Repro .odt file.

Problem description: 
Enter 65534 characters (or load the attached .odt). All is fine. Enter the 65535th character and LibreOffice starts to behave erratic and will eventually crash/deadlock.

Steps to reproduce:
See above.

Current behavior:
See above.

Expected behavior:
Should not crash.

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1
Comment 1 Andrzej Hunt 2012-09-20 20:52:03 UTC
Reproduced this in master (3.7.0.0.alpha+) on OpenSUSE 12.2 32 bit.

It seems that there's a hard limit of 65535 characters per paragraph. It is impossible to add characters at the end of the paragraph once the limit is reached, but characters can be added in the middle of the paragraph. (Initially the last line typed disappears, at some point the whole paragraph became invisible, i.e. the characters are present and selectable but invisible, and sometimes the paragraph changes from being visible to invisible if one types additional characters.)

Further paragraphs can be inserted without issues.

Setting importance to low as I assume this case is rarely reached in normal use.
Comment 2 Julien Nabet 2012-09-21 21:30:18 UTC
It's a known problem. It's not very complicated but it's quite tedious to fix because you must change lots of code.
So it's a long run task which has hopefully already started months (more than a year I would say) ago.

Caolán: could you give an update about this here or rather on fdo#30668? The link you gave here https://bugs.freedesktop.org/show_bug.cgi?id=30668#c2 is obsolete:(

*** This bug has been marked as a duplicate of bug 30668 ***
Comment 3 Michael Stahl (CIB) 2013-02-21 20:34:07 UTC
bug 30668 is about not being able to store > 64k characters;
writer should very well be able to not crash in this scenario
despite the limit.  this is rather a duplicate of bug 60732.

*** This bug has been marked as a duplicate of bug 60732 ***