Download it now!
Bug 55167 (wb2) - FILEOPEN Read-error. Error in file structure while importing. (opening an encrypted Quattro Pro WB2 file)
Summary: FILEOPEN Read-error. Error in file structure while importing. (opening an enc...
Status: RESOLVED WORKSFORME
Alias: wb2
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Format-Filters
  Show dependency treegraph
 
Reported: 2012-09-20 21:51 UTC by MetaEd
Modified: 2019-05-28 20:02 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
test case (13.07 KB, application/x-123)
2012-10-11 22:59 UTC, MetaEd
Details

Note You need to log in before you can comment on or make changes to this bug.
Description MetaEd 2012-09-20 21:51:55 UTC
Error opening a Quattro Pro WB2 file

I find in several places, notably wiki.documentfoundation.org, the statement that “Calc 3” in both OpenOffice and LibreOffice will open Quattro Pro WB2 files.

Whenever I try to open one, I get an error:

Read-error.
Error in file structure while importing.
Thinking perhaps an extension was needed, I searched the extensions catalog for a Quattro Pro extension but found none.

When I reported the problem here:
http://ask.libreoffice.org/question/4729/error-opening-a-quattro-pro-wb2-file/

I was directed to file a bug.

Cheers, Edward
Comment 1 Urmas 2012-09-22 04:56:14 UTC
Please attach a sample document.
Comment 2 MetaEd 2012-10-11 22:59:06 UTC
Created attachment 68464 [details]
test case

The attached file is the requested test case. I was able to strip the file to four simple elements: 3 cells and a password. The password is "14" (same as the file name). If I delete any of the three cells or the password then I am no longer able to reproduce the problem.
Comment 3 sasha.libreoffice 2012-11-17 08:30:36 UTC
Reproduced in 3.5.7 and 3.6.3 on RFR 17 64 bit
Another offices: Calligra Sheets tells "Encryption algorithm is closed" and Excel2007 tells "Unknown format".

Where mentioned that it should work:
http://wiki.documentfoundation.org/DE/Doku/Allgemein/B_OpenDocument
approximately middle of html page:
Tabellen-Formate die geöffnet werden können
Quattro Pro 6.0 (.wb2)
Comment 4 retired 2013-07-16 10:38:15 UTC
Does cause an error message when trying to open on OS X 10.8.4, LO 4.1.0.2.0.
Comment 5 QA Administrators 2015-04-19 03:22:32 UTC Comment hidden (obsolete)
Comment 6 Buovjaga 2015-06-18 14:07:48 UTC
Still erroring.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 437210d58f32177ef1829d704f7f4d2f1bbfbfdd
TinderBox: Win-x86@39, Branch:master, Time: 2015-06-18_07:21:56
Locale: fi-FI (fi_FI)
Comment 7 QA Administrators 2016-09-20 10:10:41 UTC Comment hidden (obsolete)
Comment 8 osnola 2017-10-04 07:55:03 UTC
Hello,
the problem still exists in:
Version: 5.4.0.2
Build ID: 2b906d450a44f2bbe506dcd22c51b3fa11dc65fd
CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; 
Locale: fr-FR (fr_FR.UTF-8); Calc: group

Just for note, as I am adding support to wb1's files in libwps(DLP) and the encryption seems similar, this file contains a password structure: the zone 4b of size 20:
- the first two bytes are a checksum of the password (which computed with the first part of libwps::encodeLotusPassword),
- the 3rd and 4st bytes seems to be the password length(to be verified),
- the last 16 bytes can be used to decrypt the files with QuattroParser::decodeStream.
Comment 9 QA Administrators 2019-05-25 02:57:28 UTC Comment hidden (obsolete)
Comment 10 osnola 2019-05-25 09:32:16 UTC
Must be fixed in LibreOffice 6.2: now it asks for a password, and opens the file if the user gives a password(*).

(*) the encryption is weak and these files are very old, so if the password is not valid, I added a function in the filter to retrieve the real password which must work if the password has less than 15 characters (see LotusParser::retrievePasswordKeys in libwps Lotus.cpp).
Comment 11 Buovjaga 2019-05-25 11:03:02 UTC
Yep I can open attachment 68464 [details] now
Comment 12 MetaEd 2019-05-28 20:02:58 UTC
I'm the one who filed the original bug report. I have checked some real-world documents. I confirm that I can no longer reproduce the problem. Thanks!