Bug 55255 - SchuDruck1 symbol font doesnt have suitable substitute font
Summary: SchuDruck1 symbol font doesnt have suitable substitute font
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Substitution
  Show dependency treegraph
 
Reported: 2012-09-23 19:58 UTC by Robert Pollak
Modified: 2016-10-23 17:40 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
the MS-Word file with import errors (56.00 KB, application/msword)
2012-09-23 19:58 UTC, Robert Pollak
Details
screenshot (18.49 KB, image/png)
2014-10-26 13:33 UTC, tommy27
Details
screenshot of different import errors with LO 5.1 (76.76 KB, image/png)
2016-02-12 22:38 UTC, Robert Pollak
Details
word 2010 pdf (285.22 KB, application/pdf)
2016-10-20 02:52 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Pollak 2012-09-23 19:58:03 UTC
Created attachment 67591 [details]
the MS-Word file with import errors

The attached "Lernwörter 1.doc" contains a lot of wrong symbols in the header (first three lines) and the second table row.

When opening the file with the proprietary app "ThinkFree Write" on my phone, the display seems correct:
- The header only contains the texts "(2. SW.)", "Name:" and "Übe diese Wörter jeden Tag! Lass sie dir auch ansagen!".
- The second table row is empty.
Comment 1 Robert Pollak 2012-09-23 20:19:15 UTC
If necessary, I can provide LibreOffice and ThinkFree screenshots.
Btw, I do not know the Word version that was used to generate the doc file.
Comment 2 Urmas 2012-09-25 18:38:00 UTC
It is rather common problem with SchuDruck1 font. Apparently it is symbol, which fact confuses LO.

The document layout is wrong also.
Comment 3 Robert Pollak 2012-09-27 20:52:48 UTC
So the SchuDruck1 font must be embedded, since "ThinkFree Write" correctly uses it. In that case this issue is a duplicate of bug 42195, isn't it?
Comment 4 tommy27 2014-10-26 13:33:29 UTC
Created attachment 108449 [details]
screenshot

tested under Win7x64 with 3.6.1.2, 4.3.2.2 and recent 4.4.0.0+ master.
bug still present in all versions.
Comment 5 QA Administrators 2015-12-20 16:21:11 UTC Comment hidden (obsolete)
Comment 6 tommy27 2015-12-20 20:03:35 UTC
bug is gone in LibO 5.0.3.1
RESOLVED WORKSFORME
Comment 7 Robert Pollak 2015-12-27 15:11:19 UTC
With LO 5.0.3.2 in Linux Mint 17.3 the document still looks as wrong as in tommy27's screenshot.
Comment 8 tommy27 2015-12-27 16:40:46 UTC
sorry, I made a mistake in comment 6.

the bug is still present under Win8.1 x64 using LibO 5.0.3.1 but is fixed using LibO 5.2.0.0.alpha0+

Build ID: 014633f83e44ae8ba33087b6f38e8e253e281969
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-12-15_06:21:44
Locale: it-IT (it_IT)

so, Robert, please test a LibO 5.1.0 RC1 or a 5.2.0 alpha daily build and tell if the issue is gone under Linux too.

if the bug is still present under Linux using 5.1.x or 5.2.x feel free to reopen the bug and change Hardware from "all" to "linux"
Comment 9 Robert Pollak 2016-02-12 22:38:33 UTC
Created attachment 122599 [details]
screenshot of different import errors with LO 5.1

Testing LO 5.1.0.3 on Windows 7, the text is now displayed with other wrong symbols, see this screenshot.
Comment 10 Yousuf Philips (jay) (retired) 2016-10-20 02:35:18 UTC
Hi Robert,

Is the issue that you dont have the SchuDruck1 font installed or that LibreOffice isnt rendering it correctly?
Comment 11 Yousuf Philips (jay) (retired) 2016-10-20 02:52:39 UTC
Created attachment 128087 [details]
word 2010 pdf

Without the SchuDruck1 font, MS Word substitutes the missing font with the Symbol font.
Comment 12 Yousuf Philips (jay) (retired) 2016-10-20 03:07:11 UTC
So telling libreoffice to substitute SchuDruck1 for Symbol in Tools > Options > Fonts solves this issue.

@Robert, @Urmas: Do you know how widely used this font is that we should attempt to fix this issue by default for users? I searched online and could barely find any information about the font or even a downloadable link.
Comment 13 Robert Pollak 2016-10-20 21:02:03 UTC
(CC'ing  Urmas)

Hello Yousuf, you were asking:
> Is the issue that you dont have the SchuDruck1 font installed or that
> LibreOffice isnt rendering it correctly?

I don't have SchuDruck1 font installed.

In Linux Mint 17, I configured SchuDruck1 to be replaced by "Standard Symbols L" to get a similar effect as yours in Word 2010. But this replacement with Cyrillic glyphs is not useful - people around here can't usually decipher them. (I even did not expect anything else than whitespace to show up, see my original bug summary.)
SchuDruck1 has latin glyphs, see the first example on http://lehrerweb.wien/service/downloads/. This website of the city of Vienna provides this proprietary font for all Viennese teachers.

I was filing this bug report under the assumption that the SchuDruck1 font was embedded into the document, but erroneously not used.
If you can confirm that it isn't embedded, this bug can be resolved as NOTABUG.
Comment 14 Yousuf Philips (jay) (retired) 2016-10-23 17:40:10 UTC
(In reply to Robert Pollak from comment #13)
> I was filing this bug report under the assumption that the SchuDruck1 font
> was embedded into the document, but erroneously not used.
> If you can confirm that it isn't embedded, this bug can be resolved as
> NOTABUG.

No the document doesnt have the font embedded.