Download it now!
Bug 55293 - Allow for wildcards in AutoCorrect feature
Summary: Allow for wildcards in AutoCorrect feature
Status: RESOLVED DUPLICATE of bug 68373
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-24 21:08 UTC by vermontpoet
Modified: 2014-04-17 21:24 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vermontpoet 2012-09-24 21:08:25 UTC
This idea springs from Bug 48892.

Joel marked this bug as low & minor. This makes me think no one is going to correct it. 

An alternate way to correct this bug would be to allow for wild cards in auto-correct. If I set up auto-correct to change '--' to an 'en-dash' or 'em-dash', it will only work if the initial dashes are discreet.

What would be useful is if auto-correct would allow for wild cards. Let's say '#' was the auto-correct wild card. I could enter the following into auto-correct:

"change" #-- to #(em or en-dash)

This means that with any word with two dashes after it (whether the dashes were discreet or not), autocorrect would correct the two dashes.
Comment 1 tommy27 2013-05-03 00:39:29 UTC
setting this as NEW. LibO autocorrect feature doesn't allow wildcards.
changing version field to first ever LibO version (3.3.0)
Comment 2 Owen Genat (retired) 2013-06-07 10:32:22 UTC
Changed "auto-correct" to "AutoCorrect" in title as that is the actual name of the facility in question and this bug was not showing up in typical searches.
Comment 3 tommy27 2014-04-17 21:24:09 UTC
autocorrect now supports the wildcard * in LibO 4.2.x
closing this and marking as a duplicate

*** This bug has been marked as a duplicate of bug 68373 ***