Bug Hunting Session
Bug 55312 - Pictures with read error when replaced before Writer has formatted complete document
Summary: Pictures with read error when replaced before Writer has formatted complete d...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: x86-64 (AMD64) Windows (All)
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: Image-Caching
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-25 10:24 UTC by Andrej
Modified: 2015-07-19 19:58 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
startin document (2.63 MB, application/vnd.oasis.opendocument.text)
2012-09-25 10:24 UTC, Andrej
Details
starting document in pdf (348.31 KB, application/pdf)
2012-09-25 10:26 UTC, Andrej
Details
read-error (48.56 KB, image/jpeg)
2012-09-25 10:27 UTC, Andrej
Details
document after (9.02 KB, application/vnd.oasis.opendocument.text)
2012-09-25 10:37 UTC, Andrej
Details
documents after (275.86 KB, application/pdf)
2012-09-25 10:37 UTC, Andrej
Details
demonstration: open document -> replacing picture -> scroll down (1.77 MB, application/x-shockwave-flash)
2013-03-17 12:38 UTC, Andrej
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrej 2012-09-25 10:24:32 UTC
Created attachment 67672 [details]
startin document

Let say I have a document "error picture 1 before.odt" with bunch of pictures (I have made "error picture 1 before.pdf" so you can see the same as I for shore). I open it, click on second picture and paste another picture (with keyboard). Than I scroll with mouse down. I get what you can see on "error.jpg" that is attached.

This thing is killing me for years now, and I finally succeed to reproduce it. Please do something about it. 

Note: if I go from beginning to the end of the document after opening the document and than replacing picture -> works fine ! But that pass through the document must be with page down or with scroll on the mouse. If it is done with Ctrl+End and Ctrl+Home, the problem persists.

After scroll and before taking the picture, I have saved the "error picture 1 before.odt" as "error picture 2 after.pdf" and "error picture 2 after.odt". Weird, I get different result. With odt, last picture is missing.

Please see the attachments.
Otherwise, libreOffice is the best :) 

Thank you
Comment 1 Andrej 2012-09-25 10:26:33 UTC
Created attachment 67673 [details]
starting document in pdf
Comment 2 Andrej 2012-09-25 10:27:04 UTC
Created attachment 67674 [details]
read-error
Comment 3 Andrej 2012-09-25 10:37:07 UTC
Created attachment 67675 [details]
document after
Comment 4 Andrej 2012-09-25 10:37:34 UTC
Created attachment 67676 [details]
documents after
Comment 5 Andrej 2012-09-25 10:48:09 UTC
hello

Any questions, please send me to  andrej8anubis@gmail.com

Thank you
Andrej
Comment 6 stfhell 2012-11-14 00:58:09 UTC
You'd better wait for someone to reproduce the bug before setting it to NEW.

I couldn't reproduce it with your files, but the bug is very familiar, of course. Other bug reports seem to associate it with the autosave function, however.

Rephrasing the summary to make it more precise. What you say is that newly inserted pictures end up as "read errors" at next file load when they are placed before Writer has completed the processing and layout of the complete document? (This background processing is usually rather slow, you can force it by paging through the complete document, or by forcing a reformat via "File/Page Preview".) Or did I get something wrong?

Adding this bug to the collection of Bug 47148.
Comment 7 Andrej 2012-11-15 12:01:35 UTC
newly inserted pictures end up fine, some of the old ends up as as "read errors". 

Open document
click on first are second picture that appears 
paste new picture so that clicked picture is replaced
then scroll the the end of the document
some pictures are "read-error"

I have just reproduced with Version 3.6.2.2 (Build ID: da8c1e6)
I get only the last one as "read-error", but I know that when I open the document it was there. Because if I open and close original document again and scroll to the end, it is there. 

Thanks
Comment 8 Andrej 2012-11-15 12:03:25 UTC
(In reply to comment #7)
> newly inserted pictures end up fine, some of the old ends up as as "read
> errors". 
> 
> Open document
> click on first are second picture that appears 
> paste new picture so that clicked picture is replaced
> then scroll the the end of the document
> some pictures are "read-error"
> 
> I have just reproduced with Version 3.6.2.2 (Build ID: da8c1e6)
> I get only the last one as "read-error", but I know that when I open the
> document it was there. Because if I open and close original document again
> and scroll to the end, it is there. 
> 
> Thanks



 click on first are second picture that appears 

should spell :
 click on first or second picture that appears
Comment 9 Andrej 2013-03-17 12:20:26 UTC
Same problem in 4.0.1.2 also.
Comment 10 Andrej 2013-03-17 12:38:56 UTC
Created attachment 76644 [details]
demonstration: open document -> replacing picture -> scroll down

demonstration: open document -> select picture -> paste and replace picture (CTRL + V) -> scroll down
Comment 11 Andrej 2013-03-17 15:18:17 UTC
I hope above demo will make things more clear. 

I have a file with bunch of pictures, when :
-------------------------------------------
opening a file (no scrolling no nothing)
select second picture 
replacing with new picture (CTRL + V)
scroll down and second picture is in error
Comment 12 Joel Madero 2013-06-26 03:52:40 UTC
Please provide exact steps (enumerated) where we can reproduce this. Unfortunately as is your steps are not very clear and they are written in a way that is very hard to follow.

What I tried:

1. Download startin document 
2. Scroll to last picture
3. Copy last picture with ctrl + c
4. Select below last picture
5. Paste with ctrl + v

I see no problem but I assume I am missing something.


If this is still a problem with version 4 please provide clearer steps and mark the bug as UNCONFIRMED. Thank you!
Comment 13 Andrej 2013-06-26 08:55:56 UTC
(In reply to comment #12)

You're steps are fine, just that paste is before scroll(no scrolling before paste, scroll after paste).

Correct steps:

1. Download and save startin document 
2. open startin document so it is writable
3. select a picture that is visible 
4. paste a picture in clip board (such as print screen)
5. scroll down
6. some pictures are missing with "read-error"

If you open document and just scroll down, are pictures are present. Seems to me that something bad happens if you paste before scroll. If you scroll thru the document before paste, everything is fine.
Comment 14 QA Administrators 2014-07-08 17:29:37 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 15 Cor Nouws 2014-07-08 22:23:57 UTC
I _sometimes_ have this too.

And it is congruent with my strong experience in Impress (bug 46447) that carefully loading a full application before reordering, or copy/paste or whatever, makes a really good change to prevent the loss of images.

Which is in line with my limited knowledge of image handling in the code: there are several in-memory copies of the document (possibly for the various views/panels too) that need some synchronising (and prolly much more).
Comment 16 QA Administrators 2015-07-18 17:43:32 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-07-18
Comment 17 Andrej 2015-07-19 19:58:19 UTC
using version 
4.4.3 on windows 7  and
4.4.4 on Linux mint

The bug is not present - resolved.