Download it now!
Bug 55369 - FORMATTING fraction displayed and treated as dates
Summary: FORMATTING fraction displayed and treated as dates
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.0.0.beta1
Hardware: Other All
: high major
Assignee: Eike Rathke
URL:
Whiteboard: target:4.0.0 target:3.6.4
Keywords: regression
: 53858 (view as bug list)
Depends on:
Blocks: mab3.6
  Show dependency treegraph
 
Reported: 2012-09-26 21:12 UTC by Horst
Modified: 2013-04-25 21:04 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Horst 2012-09-26 21:12:07 UTC
Problem description: 

Since version 3.6.xx a pre-formatted cell do not calculate the entered fraction
but applies the standard format rules to interpret the entry which results in text display in cell (left aligned).
To replicate this do the following:
1) Format col A with cell format; Numbers Fraction "# ??/??"
2) enter in cell B1 =VALUE(A1)
3) copy B1 to B2:B10 
4) Enter the data according to table
HINT: Don't use the fractions 1/2, 1/4, 3/4. They result in symbols due to autocorrect table.

Table for Fraction Format hehavior:
LO Version | Entry A | Cell Display | Input Line | B = Value(Ax)
-----------------------------------------------------------------
3.5.xx     | 1/8     |           1/8| 0.125      | 0.125
3.6.xx     | 1/8     | 1/8          | 1/8        | 40916 = 1/8/2012
3.5.xx     | 13/64   |         13/64| 0.203125   | 0.203125
3.6.xx     | 13/64   | 13/64        | 13/64      | Err502

LO3.5.xx does the right job. LO3.6.xx does not recognize the formatting 
for Fraction and interprets the entry as general format in this case tries to
make a Date out of it.

I set bug 53858 as duplicate. It had 2 different bugs described.
Comment 1 Horst 2012-09-26 21:13:11 UTC
*** Bug 53858 has been marked as a duplicate of this bug. ***
Comment 2 Julien Nabet 2012-10-06 21:55:48 UTC
On pc Debian x86-64 with master sources updated today, I reproduced the problem.

Eike: one for you?
Comment 3 Noel Power 2012-11-12 11:34:13 UTC
marking as regression, also I'll have a look
Comment 4 Eike Rathke 2012-11-12 16:14:10 UTC
I'm taking over.
Comment 5 Horst 2012-11-12 18:21:50 UTC
Don't fight over it, I have more.
Comment 6 Not Assigned 2012-11-13 13:29:38 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5391bd1e54157457abe1098b29f067d6e0059113

resolved fdo#55369 accept fraction input if preset



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Not Assigned 2012-11-13 14:01:37 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-3-6-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bb3e32b00521633e68d9a412402bb21c87c5ef90&g=libreoffice-3-6-4

resolved fdo#55369 accept fraction input if preset


It will be available already in LibreOffice 3.6.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Not Assigned 2012-11-13 14:01:57 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=97b0efc6145cd7153c724c1135eb65ee941d60d5&g=libreoffice-3-6

resolved fdo#55369 accept fraction input if preset


It will be available in LibreOffice 3.6.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Horst 2012-11-14 23:37:20 UTC
Works fine in Version 3.6.5.0+ (Build ID: 95637e2).
Comment 10 luksiw 2012-11-18 12:48:32 UTC
Fixed for version Version 4.0.0.0.alpha0+ (Build ID: 04f2f0).
Comment 11 Horst 2012-11-18 21:57:45 UTC
Works fine in Version 3.6.4.1 (Build ID: a9a0717).
Comment 12 Joel Madero 2013-04-25 21:04:20 UTC
updating version as I was able to verify that this existed in
Version 3.6.0beta1 (Build ID: 1f1cdd)
Running
Bodhi Linux 2.2

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

QA & Devs are trying to find how many bugs were introduced within a minor release of 3.6 - this was introduced during the change from 3.5 to 3.6 :)


Glad it got fixed