Bug 55384 - Reduce Bitmap option is ignored
Summary: Reduce Bitmap option is ignored
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Print-Dialog
  Show dependency treegraph
 
Reported: 2012-09-27 11:12 UTC by markus.mail
Modified: 2019-10-03 13:26 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description markus.mail 2012-09-27 11:12:06 UTC
Problem description: 

Printing documents with pictures results in huge print jobs or files. The printing option "reduce bitmap" seems to be ignored with recent versions of LibreOffice (and Apache OpenOffice as well).

The last version I could find to work is OO 3.2.1 from Debian Squeeze.

Steps to reproduce:
1. Open MyCat.odt
2. Print to a file.
3. Set "reduce bitmap" option in settings.
4. Print again to a file and compare file sizes.

Platform (if different from the browser): 
Debian Squeeze x86 and amd64

Browser: Mozilla/5.0 (X11; Linux x86_64; rv:15.0) Gecko/20120909 Firefox/15.0.1 SeaMonkey/2.12.1

The attached print files were printed via cups and a HP Business InkJet 2800 printer.
Comment 1 markus.mail 2012-09-27 11:55:38 UTC
Here is a zip file with a demo file and its print results:

http://fserver.alburg.homelinux.net/LO-55384/MyCat.zip
Comment 2 Jean-Baptiste Faure 2012-11-14 05:08:02 UTC Comment hidden (obsolete)
Comment 3 Regina Henschel 2012-11-14 16:59:44 UTC
I can confirm it. I use LO on WinXP. There should not be a need for restart, but changing it in Tools > Options should work immediately. The feature had worked in OOo3.2.1 with the old print dialog. It is broken in OOo 3.3.0 with the new print dialog. [BTW Reduce gradients is broken too.]
When you test it without wasting paper and use printing to file, remember, that you have to set it for 'printing to file' separately, see radio button on top of that dialog page.
Comment 4 QA Administrators 2015-01-05 17:51:07 UTC Comment hidden (obsolete)
Comment 5 markus.mail 2015-01-20 11:38:25 UTC
Tried with LO 4.3.5.2 on a Debian 8 amd64 system.

Problem still exists. Print to file gives the same filesize, regardless "Reduce bitmaps" settings.

The URL in comment 1 has changed to:
http://fserver.alburg.selfhost.me/LO-55384/MyCat.zip
Comment 6 QA Administrators 2016-02-21 08:34:40 UTC Comment hidden (obsolete)
Comment 7 Jean-Baptiste Faure 2016-02-21 17:49:42 UTC Comment hidden (obsolete)
Comment 8 QA Administrators 2017-03-06 14:58:36 UTC Comment hidden (obsolete)
Comment 9 Jean-Baptiste Faure 2017-04-09 08:11:37 UTC
Nothing changed with version 5.3 under Ubuntu 16.04 x86-64.

Best regards. JBF
Comment 10 QA Administrators 2018-09-06 03:00:12 UTC Comment hidden (obsolete)
Comment 11 Timur 2019-10-03 13:26:05 UTC
I guess, per my own test, that this is still valid.
But please attach sample file here (MyCat.zip or similar).