Bug Hunting Session
Bug 55393 - Some pasted text (symbols) scaled improperly
Summary: Some pasted text (symbols) scaled improperly
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.6.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-27 18:35 UTC by allen
Modified: 2013-07-05 22:10 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Some pasted text (symbols) scaled improperly (938.16 KB, application/pdf)
2012-09-27 18:35 UTC, allen
Details
correct result, created with Word 2007 (984.30 KB, application/pdf)
2012-09-27 18:36 UTC, allen
Details
PDF result from LO 4.0.4.2 (68.56 KB, application/pdf)
2013-07-01 04:31 UTC, ign_christian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description allen 2012-09-27 18:35:28 UTC
Created attachment 67799 [details]
Some pasted text (symbols) scaled improperly

Problem description: HTML pasted into document contains some math symbols that are not scaled properly, several times too large.

Steps to reproduce:
1. Select text to paste, source is from internet:  http://docs.oracle.com/cd/E19957-01/806-3568/ncg_goldberg.html#674
2. Paste into Libreoffice writer

Current behavior:
Math symbols for what ever reason are hyperlinks, so initially displayed as box with link.  Eventually Libreoffice loads images.  Most display properly, some are rendered much larger than they should.

(Exporting to PDF takes a very long time, 10x Word2007)

Expected behavior:
Word2007 behaves well.

Platform (if different from the browser): I used firefox 15.0.1 to import HTML, not chrome (had problems logging ticket with Firefox...)
              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1
Comment 1 allen 2012-09-27 18:36:32 UTC
Created attachment 67800 [details]
correct result, created with Word 2007
Comment 2 ign_christian 2013-07-01 04:31:40 UTC
Created attachment 81775 [details]
PDF result from LO 4.0.4.2

Hi Allen,

I can confirm this behavior differently on LO 4.0.4.2 (Win7 32bit).

(beta) symbol displayed correctly. But I found another symbols that was correctly shown in your result, now shown incorrectly.

I catched some of them and marked with red ovals (only severals).

Seems like regression on displaying some symbols.
Comment 3 ign_christian 2013-07-01 04:34:52 UTC
I also saw similar behavior on LO 3.6.6.2 (Win7 32bit)

About very slow response after copying & exporting to PDF, perhaps it's been reported on another bug report. You can search that & feel free to open new bug report regarding that problem.
Comment 4 allen 2013-07-01 16:34:23 UTC
I just replicated my original test case with latest LO release

Version 4.0.4.2 (Build ID: 9e9821abd0ffdbc09cd8c52eaa574fa09eb08f2)

Browser Firefox v21.0
Comment 5 ign_christian 2013-07-02 03:06:32 UTC
Have you tried resetting user profile? Please inform your OS too
Comment 6 allen 2013-07-02 22:33:07 UTC
I just reset profile, and replicated original bug.
Comment 7 allen 2013-07-02 22:42:24 UTC
OS Name	Microsoft Windows 7 Home Premium
Version	6.1.7601 Service Pack 1 Build 7601
Comment 8 ign_christian 2013-07-03 02:00:27 UTC
Strange..my result is different with yours. I think we'd better mark this UNCONFIRMED to let others test.
Comment 9 retired 2013-07-03 10:05:31 UTC
Tried to reproduce this on OS X 10.8.4 LO 4.1.0.1.

I copied the first paragraph after the heading "Floating-point Formats" from the text linked in the bug description. It starts with "Several different representations ...".

This is reproducible and always crashes LO. The log is here: http://pastebin.com/ru2zFM0K

Pasting the following did work and the image was displayed correctly.
More precisely ± d0 . d1 d2 ...

Not sure where the culprit of this lies. But setting to new. Maybe a dev can elaborate if this is more than one bug and how to proceed.

Setting to NEW.
Comment 10 retired 2013-07-03 10:05:51 UTC
Tried to reproduce this on OS X 10.8.4 LO 4.1.0.1.

I copied the first paragraph after the heading "Floating-point Formats" from the text linked in the bug description. It starts with "Several different representations ...".

This is reproducible and always crashes LO. The log is here: http://pastebin.com/ru2zFM0K

Pasting the following did work and the image was displayed correctly.
More precisely ± d0 . d1 d2 ...

Not sure where the culprit of this lies. But setting to new. Maybe a dev can elaborate if this is more than one bug and how to proceed.

Setting to NEW.
Comment 11 Michael Stahl (CIB) 2013-07-05 22:10:05 UTC
the crash is bug 66324 and is unrelated to any document formatting.

and the description talks about _images_ while the comment #2
suddenly talks about "p" which is not an image but an actual
_character_ in the text (using an entirely different LO version too).

can't reproduce the badly scaled image from the description on current
master or 4.0 on Linux.

the characters marked in comment #2 all are italic "Arial;Helvetica":

  <font face="Arial,Helvetica"><em>p</em></font>

i can't see any difference in rendering of that between
LO 3.5.7 and 4.0.1 on Windows and Word 2010.
LO master on Linux renders it a little differently but that is
most likely due a different platform specific font rendering library.

since this report vaguely talks about 3 different issues
and nothing seems to be obviously wrong to me i'll just resolve it WFM.