Bug 55399 - Writer crashes or does not respond
Summary: Writer crashes or does not respond
Status: RESOLVED DUPLICATE of bug 55156
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.1.2 release
Hardware: x86-64 (AMD64) macOS (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-28 03:24 UTC by eastasiax
Modified: 2013-12-17 13:04 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
attachment is the report when the writer lost response. it is generated by mac os x lion. (287.87 KB, text/rtf)
2012-09-28 03:24 UTC, eastasiax
Details

Note You need to log in before you can comment on or make changes to this bug.
Description eastasiax 2012-09-28 03:24:48 UTC
Created attachment 67806 [details]
attachment is the report when the writer lost response. it is generated by mac os x lion.

Problem description: 
when opening a file for editing (writer)(about 90 pages), if I moves pages quickly, the writer crashed.
or when i open the preferences dialog, and click the options on the left, then the program does not responding.
Steps to reproduce:
1. open a odf document
2. move throught pages quickly for finding the page to be viewed or click LibreOffice->preferences... (command+,), then click any option on the left
3. the program crashed or not reponded

Current behavior:
i have to reopen my file and go through pages slowly and worry when it crashes again, and try not to open the preferences dialog for configuring
Expected behavior:
i hope libreoffice is stable for productivity on mac.


Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:15.0) Gecko/20100101 Firefox/15.0.1
Comment 1 Roman Eisele 2012-09-28 08:15:40 UTC
Thank you very much for your bug report!

From the stack trace in the Mac OS X report you have attached, I see that
this problem is related to the Mac Accessibility API. This means

1) that you have activated some option in System Preferences >
   “Universal Access”, most probably “Enable Access for assistive devices”,
   but maybe also “VoiceOver”, “Zoom”, etc.;

and/or

2) that you have installed some third-party window management or
   cursor utility/application, i.e. a little application, app or extension
   which helps to arrange, resize, restore the user interface windows
   or manages the mouse cursor, like
   * AquaSnap         * DoublePane     * RightZoom    * TileWindows
   * BetterSnapTool   * Flexiglass     * ShiftIt      * WindowTidy
   * BetterTouchTool  * HyperDock      * SizeUp
   * Breeze           * iSnap          * SizeWell
   * Cinch            * LazyMouse      * Spectacle
   * Divvy            * Moom           * Stay
   and many others ...
   -- my best guess is Cinch or Moom! --;

and/or

3) that you use some text-to-speech or speech-to-text (dictation) software
   or other special software or hardware.

Could you please check if any of these points applies?

The use of the Mac Accessibility API is known to cause many crashes and hangs in LibreOffice (and other applications), therefore it will very probably help to deactivate the accessibility setting or the window management utility or whatever, or (if possible, like in RightZoom and LazyMouse) to add LibreOffice to the list of excluded applications.

Please try this, and report the results here by adding an additional comment.

Thank you very much!


(Internal QA hint: this is very probably a duplicate of bug 55156,
compare the stack traces!)
Comment 2 eastasiax 2012-09-29 07:30:35 UTC
hi, Roman. thanks very much. 

i tried methods #1, just untick "Enable Access for assistive devices" it works. i opened my file again and again and moved through pages very quickly and now the program stays well.
    btw, before diable it, i didn't active any of the options. it is all default configuration.

i just installed the soft i need, and none of them is related to those in method #2.

because method #1 solved the problem, two dictionary soft opened while testing #1,and the office also works well, so the hanging or crash was not related to these two soft -- dictionaries from Apple and eudic from eudic.net.

hope libreoffice grows more stronger!
Comment 3 Roman Eisele 2012-09-30 11:50:30 UTC
@ eastasiax:

thank you very much for your detailed reply!

*

Because eastasiax has confirmed that "Enable Access for assistive devices" was activated, and because the stack trace in his log file is mostly identical to the one of bug 55156, the reason of this crash seems to be the same as in bug 55156.

This is good, because bug 55156 is already fixed (or band-aided); the fix will appear in LibreOffice 3.7 (and probably backported to LibreOffice 3.6.3).

*** This bug has been marked as a duplicate of bug 55156 ***