Bug 55457 - Highlight button sticks
Summary: Highlight button sticks
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: x86-64 (AMD64) Linux (All)
: medium enhancement
Assignee: sdc.blanco
URL:
Whiteboard: target:7.2.0
Keywords:
Depends on:
Blocks: Highlight-Color-Button
  Show dependency treegraph
 
Reported: 2012-09-30 03:32 UTC by A.R.
Modified: 2021-08-25 13:07 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description A.R. 2012-09-30 03:32:06 UTC
When selecting text to be highlighted, after the text has been highlighted, the highlighting function does not turn off.  When typing new text, the text seems to be automatically highlighter (did not want this to happen).  When you go to click the highlight button to turn it off, it does not turn off.  What I end up having to do is to selct the text that was automatically highlighted and select "no fill" to remove the highlight.
Comment 1 Brenda Granados 2013-03-06 16:26:38 UTC
I have confirmed this behavior. Here is how to see the issue:

1. In a new Writer document, begin typing: "This is text to modify"
2. Highlight the word "modify" using your mouse.
3. Click on the highlight feature on the toolbar. This should turn the highlight feature on.
4. After highlighting the word "modify", click the highlight tool, or press ESC.
5. Use spacebar, then keep typing.

Expected Result: Subsequent text is not highlighted. Highlight is "off".
Actual Result: Highlighting continues. Highlight is still "active".

At this point, you will have to use your mouse to highlight the new text, and click the Highlight menu dropdown next to the Highlight feature, and select no fill. Then you can continue to type without the highlight.

Another way to avoid this is to make sure there is a space entered after the word "modify", and use your mouse to highlight everything but the space. Then highlight works as expected.

According to the LibreOffice Help about highlighting, Highlight "Applies the current highlight color to the background of a text selection.". So the behavior might be intentional, because text that extends after "modify" might be considered part of the selection.  But I think the text selection should only be considered the actual current selection.

Version: 4.0.1.0+ (Build ID: 3e8af168ca227529b752abb9c7aecc42be4a229)
Platform: Ubuntu Linux x64


-Brenda

--------------------------------------

LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link: https://wiki.documentfoundation.org/QA/BugTriage  There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists
Comment 2 Brenda Granados 2013-03-06 16:42:00 UTC
Marking as NEW, ENHANCEMENT. I am not sure if this something that will change, because I think it might be acting according to the documentation. It is certainly worth looking into, though.
Comment 3 sdc.blanco 2021-01-19 15:31:20 UTC
STR in comment 1 is still valid for 7.2.0.0.alpha0+

Similar situations appear (e.g., when copying text to footnotes).

Seems worth evaluating whether this request is WF, NOTABUG, etc.

Also, if no changes will be made, and you can see a way to improve the documentation in relation to this situation, then would appreciate a suggestion. (I could not see any obvious way to indicate it.)

https://help.libreoffice.org/7.2/en-US/text/shared/02/02160000.html
Comment 4 Heiko Tietze 2021-01-20 18:34:44 UTC
This is a convenience feature and by design. You have to press the button again or escape to exit the highlight mode.
Comment 5 sdc.blanco 2021-01-21 12:15:23 UTC
(In reply to Heiko Tietze from comment #4)
> This is a convenience feature and by design. You have to press the button
> again or escape to exit the highlight mode.
Actually, the case in comment 1 does use that method.

But there are other appropriate actions available.
Between steps 4 and 5 in comment 1, use either 

"Format > Clear Direct Formatting"   or 
Crtl-M   (.uno:ResetAttributes) or 
Ctrl+Shift+X (.uno:RemoveDirectCharFormats)

which turns off highlighting.

Otherwise, I agree, by design and WF.
Comment 6 Commit Notification 2021-01-21 19:39:38 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/18c3e6381615108470e2a17a786b317cc326561f

Related to: tdf#55457  how to turn off highlighting after text selection