Bug Hunting Session
Bug 55544 - Cut/paste columns (or rows) causes superfluous steps
Summary: Cut/paste columns (or rows) causes superfluous steps
Status: RESOLVED DUPLICATE of bug 39936
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.1.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-02 14:26 UTC by Rusty S
Modified: 2013-05-30 17:59 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rusty S 2012-10-02 14:26:21 UTC
Scenario 1: User wishes to re-order columns. ABC should become ACB. User cuts Column B and attempts to paste after Column C.

Result 1: Columns A, (blank) B, C, D. Column D has content from former column B.

Desired result 1: Columns A, B, C. Column C has content from former column B. Column B has content from former column C.


Scenario 2: User wishes to re-order columns. ABCD should become ACDB. User cuts Column C and D, and attempts to insert-paste between column A and B, by selecting column B and right-clicking to find option to insert-paster rather than overwrite-paste.

Result 2: Calc offers no option to insert-paste. User must first insert sufficient blank columns before cut and paste...

Desired Result 2: Calc should offer an option to paste and insert cut or copied columns. Ditto for rows.
Comment 1 Joel Madero 2013-05-30 17:59:14 UTC
I'm confident this is a duplicate of: bug #39936

Marking as such.

@Rusty - there is a hefty discussion on that bug, with a workaround (and I believe a keyboard shortcut method to do what you are trying to do)

*** This bug has been marked as a duplicate of bug 39936 ***