Bug 55546 - Long field tooltips crash some Linux systems
Summary: Long field tooltips crash some Linux systems
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other Linux (All)
: high critical
Assignee: Caolán McNamara
URL:
Whiteboard: BSA target:4.4.0 target:4.3.4
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-02 14:47 UTC by Robert Knight
Modified: 2015-04-16 20:38 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Knight 2012-10-02 14:47:20 UTC
When hovering the mouse over a field created by an add-in in LibreOffice, the complete field code for the field is displayed in the tooltip.  If the field code is lengthy, this can result in a very wide tooltip window being created.

Aside from looking ugly, this can cause some Linux systems with certain graphics drivers (NVidia and nouveau seem to be affected in particular when using Compiz or Gnome Shell) to hang.

This affects users of the Mendeley Desktop and Zotero reference management tools which both use field codes to store JSON blobs containing complete metadata for cited documents.

See the 'Hovering over Zotero citations in LibreOffice makes Compiz and Gnome Shell crash' section at http://www.zotero.org/support/word_processor_plugin_troubleshooting and Mendeley issues http://support.mendeley.com/customer/portal/questions/531105-libreoffice-plugin-crashes-gnome-3 , http://support.mendeley.com/customer/portal/questions/278350-openoffice-3-2-mendeley-desktop-1-3-2-ubuntu-1-4-lts-black-bar-spans-all-monitors-on-hover
Comment 1 Robert Knight 2012-10-03 11:45:00 UTC
For more details on an affected system, see http://forums.zotero.org/discussion/23098
Comment 2 Joel Madero 2012-10-03 17:57:41 UTC
I'm confused by the link you provided, it says specifically that they think it's a Ubuntu issue....are you suspecting that it's a LibO issue? Also, is there any way that you can just attach a document that we can quickly open and hover over to see the crash? Marking as NEEDINFO. Please comment and attach document if possible then reopen as UNCONFIRMED. Thanks for your patience, we'll try to track this down if it's our bug
Comment 3 Nicola 2012-11-25 11:14:32 UTC
(In reply to comment #2)

It is not an Ubuntu issue, the same happens under FC16.
Comment 4 Andor Kiss 2013-02-20 13:56:20 UTC
The workaround is to go into LibreOffice>Tools>Options

Uncheck 'Tips'

Close Dialogue
Comment 5 Joel Madero 2013-02-20 18:08:10 UTC
As two users independently see the issue, marking as NEW and prioritizing.

Critical (crash, loss of data)
High (default, seems appropriate)

@Users - please update version field for what the earliest version you see this issue on. Thanks!
Comment 6 Robert Knight 2013-02-20 18:17:26 UTC
Hello Joel,

The affected versions of OpenOffice are 'whatever versions have displayed the full field code in field tooltips'.  I'm afraid I don't know what version that is but I know it has been an issue since the pre-LibreOffice era.  I suspect the problem came to light initially not because of a change in OpenOffice but because users starting using (Compiz, Graphics driver) combinations which exhibited the problem.

I'd hope the fix should be relatively simple - elide the tooltip for fields since it isn't useful to have them longer than say, Tweet-length.
Comment 7 Aurelien Naldi 2013-05-16 08:32:07 UTC
I have been affected as well on fedora 18 (LO 3.6.6), running gnome-shell (3.6) and with citation inserted by mendeley instead of zotero.
Disabling tips solves it for now, but I do miss them in other areas: truncated tips would be so much better!

Did anyone test if this still happens with LO 4.0 ?
Comment 9 Robert Knight 2014-10-09 12:06:46 UTC
Thanks Caolán!
Comment 11 andis.lazdins 2015-03-23 14:26:12 UTC
Is this really fixed?
I'm using 4.3.6.2 Ubuntu 14.04 32 bit with MATE and the problem with long tootips still exists, I would say it is even worse. And workaround with switching off tooltips still works.

Regards
Comment 12 Joel Madero 2015-03-23 14:34:27 UTC
Can you try with 4.4 - if you still see the problem in 4.4 then let's REOPEN this and get some additional input.
Comment 13 andis.lazdins 2015-03-23 14:56:37 UTC
(In reply to Joel Madero from comment #12)
> Can you try with 4.4 - if you still see the problem in 4.4 then let's REOPEN
> this and get some additional input.

The same story with 4.4.2.1. Empty page with multiple Zotero reference (6 references together). On mouse over reference 1 CPU goes 100% and program is not responsible for about 40 seconds. No problems if tips are unchecked.

I guess this problem is described here as well https://bugs.documentfoundation.org/show_bug.cgi?id=86793
Comment 14 Joel Madero 2015-03-23 15:11:10 UTC
@Caolan - any ideas as to how we can proceed given that one user at least is still seeing the crash. Thanks
Comment 15 Michael Stahl (CIB) 2015-04-16 20:35:48 UTC
slowness is reported separately as bug 86793, closing this one