Bug Hunting Session
Bug 55567 - UI: Find Bar incomplete, empty, input pane is missing
Summary: UI: Find Bar incomplete, empty, input pane is missing
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: All All
: medium major
Assignee: Ivan Timofeev (retired)
URL:
Whiteboard: BSA target:3.7.0
Keywords: regression
Depends on:
Blocks: mab4.0
  Show dependency treegraph
 
Reported: 2012-10-03 09:34 UTC by Rainer Bielefeld Retired
Modified: 2012-10-07 19:40 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-10-03 09:34:41 UTC
Steps how to reproduce with parallel installation of Master "LOdev  3.7.0.0.alpha0+   -  ENGLISH UI / German Locale  [Build ID: c7e559]"  {tinderbox: @16, pull time 2012-10-03 05:46:26} on German WIN7 Home Premium (64bit):

1. Open blank new WRITER document from LibO Start Center
2. Menu 'View -> Toolbars', uncheck "Find" if necessary
3. Menu 'Edit -> Find'
   You should see something like a toolbar appear, but 
   only a handle appears, toolbar is without input pane and
   similar
4. If Find Bar is docked, Undock (Drag and drop to somewhere
   in the document area)
   You still see the empty bar
5. Redo from Step 2
   In step 3 you again only will see the empty bar without 
   input pane.

Find and replace dialog appears as expected.
              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20120909 Firefox/15.0.1 SeaMonkey/2.12.1
Comment 1 Rainer Bielefeld Retired 2012-10-06 14:11:39 UTC
[Reproducible] with Server-installation of Master "3.7.0.alpha0+  – ENGLISH UI [Build ID: b255de8]" {tinderbox: Win-x86@16, pull time 2012-10-06 09:31:39} on German WIN7 Home Premium (64bit) UserInstallation=$SYSUSERCONFIG/LOdev/3

May be we can also check other OS?
Comment 2 Julien Nabet 2012-10-06 14:33:45 UTC
On pc Debian x86-64 with master sources updated today (d1439...), I reproduced the problem.
I must add that when I select "find", I've got "Find" toolbar checked and can uncheck it but when find isn't checked, I can't see it in Views Toolbar.

I don't know if it's linked but when I click on "Edit", I've got this on console:
(soffice:21815): GLib-GObject-CRITICAL **: g_object_ref: assertion `G_IS_OBJECT (object)' failed
(soffice:21815): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
several times

When I click on "Insert" menu, I've got this additionnal trace:
warn:legacy.osl:21853:1:/home/julien/compile-libreoffice/libo/comphelper/source/misc/namedvaluecollection.cxx:225: NamedValueCollection::impl_assign: encountered a value type which I cannot handle:
com.sun.star.awt.XWindow

(put all since it's reproduced with Linux too)
Comment 3 Roman Eisele 2012-10-06 17:06:00 UTC
REPRODUCIBLE also on Mac OS X 10.6.8 (Intel) with LOdev 3.7.0.0.alpha0+ (Build ID: dd11a1e; pull time: 2012-10-04 12:52:50). If I try to show the “Find” palette window/toolbar widged, only “something like a toolbar” (as Rainer put it nicely) appears: A completely empty, white nothing with a frame and a closebox, but no controls in it.
Comment 4 Not Assigned 2012-10-07 18:31:04 UTC
Ivan Timofeev committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ccb65352599dc2cc0b561d01ac12a513705d936d

fdo#55567: add findbar.xml back to makefile



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Ivan Timofeev (retired) 2012-10-07 18:33:33 UTC
Thanks for the report, fixed now.
Comment 6 Julien Nabet 2012-10-07 19:40:52 UTC
Thank you Ivan, i've just a made a simple test and that's ok.