Bug Hunting Session
Bug 55585 - Should check all XKB group indexes when matching key events for accelerators and mnemonics
Summary: Should check all XKB group indexes when matching key events for accelerators ...
Status: RESOLVED DUPLICATE of bug 41169
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-03 16:25 UTC by Rui Tiago Matos
Modified: 2013-11-07 13:22 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rui Tiago Matos 2012-10-03 16:25:01 UTC
It seems that LibreOffice checks only XKB group index 1 when matching key events for accelerators and mnemonics. This means that a user typing, say Hebrew, with the following configuration:

$ setxkbmap "il,us"

won't be able to trigger accelerators (like Ctrl+C) or mnemonics (like Alt+F).

This is problematic especially under Gnome >= 3.6 because we've changed the way that layouts are configured. While previously users would be able to work around this bug by having the "us" layout before the "il" layout, now that's not possible because Gnome doesn't rely on the XKB group index anymore and always configures the layout which the user intends to type with on XKB group index 1 and then adds "us" to another index implicitly so that this issue wouldn't happen on GTK+ (which does check all group indexes as I suggest and thus works correctly).
Comment 1 Yotam Benshalom 2012-10-04 21:42:04 UTC
Just to make sure this is clear:
This bug renders LibreOffice unusable in all non-latin gnome 3.6 environments,
Comment 2 Lior Kaplan 2012-11-10 14:01:38 UTC
I couldn't reproduce to problem with Gnome 3.4.2 and LibreOffice 3.6.2.

Steps:
1. Open a new document and type some Hebrew
2. while still being on Hebrew keyboard layout, hit CTRL+C
3. while still being on Hebrew keyboard layout, hit CTRL+V

The result is that the text is pasted.
Comment 3 Joel Madero 2013-07-02 05:35:11 UTC
we need reproducible steps here, also a response to Lior's comment would be helpful.

Marking as NEEDINFO - once steps are provided + Lior's comment is addressed mark as UNCONFIRMED and we will look into it.

Thanks for helping us make LibreOffice better for everyone :-D
Comment 4 Yotam Benshalom 2013-07-02 09:07:55 UTC
β€ŽThe current situation is not as grim as depicted in the first post, but it is still a buggy one.
Using Gnome 3.8 from GNOME# Team PPA, I can trigger a buggy behaviour like this:

1. In the Gnome Region and Language preferences set two layouts: Hebrew (lyx) and English (US). Make sure that Hebrew is listed ABOVE English.
2. Set the current layout to Hebrew.
3. Open a LibreOffice document and try to copy and paste text using accelerators (Ctrl+C, Ctrl+V).
4. The result: Nothing will happen.

As a workaround, make sure that Hebrew is listed BELOW English in the Gnome preferences.

The situation with mnemonics is different, and it may be worthy of openning two new bugs. Using the Hebrew UI of Libreoffice 4.0.4.2, most of the menues and commands have no mnemonics at all (bug #1), and the ones that do have them work only when the current layout is set to Hebrew (bug #2).
Comment 5 Rui Tiago Matos 2013-11-07 13:22:17 UTC

*** This bug has been marked as a duplicate of bug 41169 ***