Download it now!
Bug 55592 - wish: color replacer tool to work for whole document, not just a specific image
Summary: wish: color replacer tool to work for whole document, not just a specific image
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 55904 86608 86960 (view as bug list)
Depends on:
Blocks: BlockDiagram
  Show dependency treegraph
 
Reported: 2012-10-03 19:41 UTC by Richard Neill
Modified: 2016-09-04 16:15 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Neill 2012-10-03 19:41:08 UTC
I'd like to be able to use the color replacer tool for the whole document (or any selected subset). 

So, for example, I've got 10 copies of a 20-element group, of which 12 parts are in 10%-grey. I'd like to be able to use the replacer to make all of these into 
20%-grey. 

[At the moment, the tool only works on images]

Thank you for your time and consideration.
Comment 1 Joel Madero 2013-11-24 16:06:19 UTC
Thank you for reporting this enhancement request! I can confirm that this is a valid enhancement request on:
Version: 4.2.0.0.alpha0+Build ID: 09a4c4d176ff97ab8ff4027af83a549991667baf
Date:   Sat Nov 16 20:32:43 2013 +0100 
Platform: Ubuntu Linux 13.04 x64
+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
As I've been able to confirm the enhancement request I am marking as:

New (confirmed)
Enhancement
High - it seems like this is a really nifty idea and includes a couple nice (similar) enhancements. Marking as High because it's a big time saver and actually part of it is not currently possible with color replacer (ie. if you want to change the color of anything other than a picture it's impossible in Draw)

a)Don't limit replacement to just images (draw objects should be included also)
b) If no picture or object is selected, the whole page is replaced


+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 2 Kevin Suo 2014-12-03 06:35:38 UTC
*** Bug 86608 has been marked as a duplicate of this bug. ***
Comment 3 Kevin Suo 2014-12-03 06:36:11 UTC
*** Bug 55904 has been marked as a duplicate of this bug. ***
Comment 4 Kevin Suo 2014-12-03 06:36:31 UTC
*** Bug 86960 has been marked as a duplicate of this bug. ***
Comment 5 Heiko Tietze 2016-06-08 07:52:01 UTC
The color replacer is an image manipulation tool and not working on any other object. To take the dialog for other functions is kind of abusing it.

And actually we have a much better approach to it: styles. Just define a style with 10% grey and apply it to the shapes that should be similar. When you change any property of the style later it will affect the objects with this style. Does this work for you?

Set importance to medium, and status needinfo because it's an old ticket.
Comment 6 RichardNeill 2016-09-04 16:15:06 UTC
Re #5, I'm not sure that's quite right.

The problem would then become one of "automatically find all elements by colour, and apply a given style to them".

The challenge here is not so much about editing documents created in the "right" way (i.e using styles, and using a clear "html vs css" division) as of editing long documents that have already been created, by "normal" users who have applied direct manual formatting to each element (and where the document may have originated in MS Word).