Bug Hunting Session
Bug 55712 - FILTER: Autofilter incorrect if filtered cells are referenced in formulas
Summary: FILTER: Autofilter incorrect if filtered cells are referenced in formulas
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: Other All
: medium major
Assignee: Markus Mohrhard
URL:
Whiteboard: BSA target:3.7.0 target:3.6.3
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-10-07 06:05 UTC by pierre-yves samyn
Modified: 2013-04-27 15:56 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
NotUsedInFormula.ods (9.46 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-10-07 06:05 UTC, pierre-yves samyn
Details
UsedInFormula.ods (10.06 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-10-07 06:06 UTC, pierre-yves samyn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pierre-yves samyn 2012-10-07 06:05:28 UTC
Created attachment 68187 [details]
NotUsedInFormula.ods

Hello

Steps to Reproduce

1. Open the attached spreadsheet NotUsedInFormula.ods
2. Click in A1 to open the AutoFilter list box 

Expected and actual results: 8 values ​​displayed

3. Open the attached spreadsheet UsedInFormula.ods

Same spreadsheet with cells in column C refers to cells of the filtered area by formulas such as: =IF(A2=1, 1)

4. Click in A1 to open the AutoFilter list box 

Expected Result: 8 values ​​displayed
Actual result: 15 values ​​displayed

5. Delete Column C
6. Click in A1 to open the AutoFilter list box 

Expected and actual results: 8 values ​​displayed

Reproduced with Version 3.6.3.0+ (Build ID: 1e73405)
Reproduced (fr-discuss)

This bug seems to be related (or have a different effect) of bug 54552


Regards
Pierre-Yves
Comment 1 pierre-yves samyn 2012-10-07 06:06:08 UTC
Created attachment 68188 [details]
UsedInFormula.ods
Comment 2 Markus Mohrhard 2012-10-12 04:37:10 UTC

*** This bug has been marked as a duplicate of bug 53814 ***
Comment 3 pierre-yves samyn 2012-10-13 05:34:57 UTC
(In reply to comment #2)
> 
> *** This bug has been marked as a duplicate of bug 53814 ***

Hello Markus

I confirm that the bug 53814 has been resolved: I reproduce with Version 3.6.2.2 (Build ID: da8c1e6)and do not reproduce more with Version 3.6.4.0+ (Build ID: a010c4e)

However I have to reopen this bug since 3.6.4 did not solve.

Steps to reproduce are the same.

Regards
Pierre-Yves
Comment 4 Not Assigned 2012-10-17 13:55:52 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=622f7751b78fd8584e34f5fa96a04ed6e8bb98f5

ignore broadcaster cells to fill autofilter dialog, fdo#55712



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Not Assigned 2012-10-19 08:27:15 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=637096b75f2989640967e72aee41e48b07a5a602&g=libreoffice-3-6

ignore broadcaster cells to fill autofilter dialog, fdo#55712


It will be available in LibreOffice 3.6.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Not Assigned 2012-10-22 13:39:00 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-3-6-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a25776ae243646179a0bb3cd7f16a6d46f09b4cf&g=libreoffice-3-6-3

ignore broadcaster cells to fill autofilter dialog, fdo#55712


It will be available already in LibreOffice 3.6.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 pierre-yves samyn 2012-10-27 04:53:02 UTC
Hello

Verified as fixed with Version 3.6.4.0+ (Build ID: b1f308d) and Windows 7 64bits

Thank you very much :)

Regards
Pierre-Yves
Comment 8 Jean-Baptiste Faure 2012-10-28 21:00:08 UTC
Verified in LO 3.6.3.2

Thank you.
Comment 9 Joel Madero 2013-04-27 15:56:33 UTC
As part of regular FDO maintenance we are checking minor release regression versions to ensure that it was introduced during a minor release.

I can confirm essentially this exact behavior on 3.6.0.4 release (deleting column C doesn't fix anything, else same behavior).

Updating version