Download it now!
Bug 55715 - FILESAVE: Writer creates corrupt docx when a chart is copied from calc
Summary: FILESAVE: Writer creates corrupt docx when a chart is copied from calc
Status: RESOLVED DUPLICATE of bug 40594
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.1.2 release
Hardware: Other All
: highest critical
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-07 08:00 UTC by szz
Modified: 2013-05-22 22:29 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
ods , odt and corrupt docx sample files (24.68 KB, application/zip)
2012-10-07 08:00 UTC, szz
Details
How it looks like in Word for Mac 2011 (115.61 KB, image/png)
2013-03-03 22:00 UTC, Jorendc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description szz 2012-10-07 08:00:51 UTC
Created attachment 68190 [details]
ods , odt and corrupt docx sample files

Problem description: 
I am not able to save doc. with chart as docx format (MS Word 2007/2010 XML) because file is always corrupt.

Steps to reproduce:
1. create an chart in CALC and leave it open
2. create a new Writer text document and copy-paste chart from CALC to WRITER
3. save as docx
4. open it in MW word or Libre office

Current behavior:
- When docx file is opened in In Libre Office chart is missing.
- When it is opened in MS Off Word 2003 error message appears: "There was an error opening the file"

Expected behavior:
correct docx file 

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 5.1; rv:15.0) Gecko/20100101 Firefox/15.0.1
Comment 1 szz 2012-10-07 08:28:52 UTC
In case of text only content docx file was correct for me.
Comment 2 szz 2013-03-02 19:43:27 UTC
The problem still exists in LO 4.0.0.3 (portable) so I have changed the release to 4.0.0.3.
Comment 3 Jorendc 2013-03-03 21:43:21 UTC
Thanks for reporting.

I followed your steps to create testcase.

I can't confirm that it resolve in a corrupt docx, but I can confirm that opening the file using Word (for Mac 2011) result in an empty document. When you click in the document where the table should be, it selects an empty rectangle.

Opening the file again using LibreOffice shows the table correctly.

Tested using Mac OSX 10.8.2 and LibreOffice 4.0.1.2 rc.

@bug reporter: the bug version is the old version of LibreOffice you can reproduce this behavior. Therefore I mark this again as a bug of 3.6.1.2.

Kind regards,
Joren

-------------------
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link: https://wiki.documentfoundation.org/QA/BugTriage  There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-list
Comment 4 Jorendc 2013-03-03 22:00:16 UTC
Created attachment 75865 [details]
How it looks like in Word for Mac 2011
Comment 5 Jorendc 2013-03-03 22:10:35 UTC
Sorry for the noise, I was copying the *table* not the chart as you said. I can fully confirm your behavior (corrupt file message in word and data loss when reopening using LibreOffice). Also reproducible using LibreOffice Version 4.1.0.0.alpha0+ (Build ID: 5fcb553c862d407aadb0320925723d3c2f70bfe)
TinderBox: MacOSX-Intel@1-built_no-moz_on_10.6.8, Branch:master, Time: 2013-02-26_22:56:53

This result in data loss and I think this is a very common used function. Therefore I mark this as Highest Critical and I'm going to place it on the MAB-list.

Kind regards,
Joren
Comment 6 Owen Genat (retired) 2013-05-22 01:13:46 UTC
Is this bug related to #40594 ? From what I can tell they appear to be. I just wanted to include a reference here for clarity, but will leave it to someone with more knowledge to confirm if this is the case or not.
Comment 7 Jorendc 2013-05-22 22:29:06 UTC
(In reply to comment #6)
> Is this bug related to #40594 ? From what I can tell they appear to be. I
> just wanted to include a reference here for clarity, but will leave it to
> someone with more knowledge to confirm if this is the case or not.

Thanks for your search and comment Owen. Really appreciated. I read the bug report and at first I wouldn't mark it as a duplicate, but when reading this https://bugs.freedesktop.org/show_bug.cgi?id=40594#c11 (comment 11) it is almost sure this is a duplicate.

Thanks to Owen we can mark it as such.
@Bug reporter: if this behavior us still reproducible after bug 40594 is fixed, please REOPEN this bug.

Kind regards,
Joren

*** This bug has been marked as a duplicate of bug 40594 ***