Bug Hunting Session
Bug 55833 - Lacking support for KDE 4.x addressbooks (akonadi)
Summary: Lacking support for KDE 4.x addressbooks (akonadi)
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Address-Source
  Show dependency treegraph
 
Reported: 2012-10-10 10:08 UTC by Martin Tlustos
Modified: 2019-06-14 12:11 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Tlustos 2012-10-10 10:08:53 UTC
Problem description: 
I can not access my contacts stored in KDE addressbooks/akonadi
Steps to reproduce:
1. Open File/Assistant/Address-Source
2. look for option to add kde addressbook
3. ....

Current behavior:
Nothing shows up
Expected behavior:
Possibility to access this data
Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:16.0) Gecko/20100101 Firefox/16.0
Comment 1 bfoman (inactive) 2013-05-02 13:19:01 UTC
Enhancement feature.
Comment 2 tommy27 2014-01-02 18:19:13 UTC
(In reply to comment #1)
> Enhancement feature.

so we can mark it as NEW.

@Martin
have you tried LibO 4.1.4.2? is issue still there?
Comment 3 Martin Tlustos 2014-01-13 07:51:51 UTC
Issue is still there in LO 4.1.3.2 from the Ubuntu repos.

The problem is that addressbooks can be local files (vcf format), caldav ressources or google addressbooks, and different people use different ones as their standard addressbook (I use google).So the easiest way to implement all of them would probably be to write a connector to akonadi.
Comment 4 Xisco Faulí 2019-06-13 15:45:21 UTC
Dear martin Tlustos,
KDE4 support has been dropped in LibreOffice 6.3.
Could you please try to reproduce it with LibreOffice 6.3 Beta1 from https://wiki.documentfoundation.org/QA/GetInvolved#Test_Pre-releases ?
You can install it alongside the standard version.
I have set the bug's status to 'NEEDINFO'. Please change it back to 'NEW' if the bug is still present in the master build
Comment 5 Martin Tlustos 2019-06-14 12:11:40 UTC
The problem is the same with KDE/Plasma 5. No way to integrate my kontact/akonadi addressbook (nor Google, by the way), so creating mail merge without first exporting addresses into a file.