Bug Hunting Session
Bug 55960 - Filling cells with incremental numbers – wrong numbers
Summary: Filling cells with incremental numbers – wrong numbers
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Number-Format
  Show dependency treegraph
 
Reported: 2012-10-13 22:11 UTC by V.K.
Modified: 2017-09-17 18:06 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file with two filled number sequences (11.34 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-10-13 22:11 UTC, V.K.
Details
Floating point error when dragging a list to auto fill (12.62 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-02-04 11:38 UTC, sharkylaser
Details

Note You need to log in before you can comment on or make changes to this bug.
Description V.K. 2012-10-13 22:11:55 UTC
Created attachment 68541 [details]
Example file with two filled number sequences

On some step of filling cells with incremental numbers, numbers become wrong.
E.g. 1.000000001 instead of 1

How to reproduce:
1. Type -2 in a cell
2. Type -1.95 in the cell below the previous one
3. Select both cells
4. Drag cell border as usual to fill column (using square marker)
5. Starting from -1 numbers become wrong
(See example file with another sequence too)

Libreoffice 3.6.2.2
Windows 7 SP1 32 bit
Comment 1 billhook 2012-10-14 23:48:09 UTC
Confirmed on LO 3.6.3rc1 Windows Vista 32 bit.

It looks like it is using Floating Point arithmetic instead of decimal to calculate the values.
Comment 2 Owen Genat (retired) 2013-11-18 07:31:33 UTC
Still reproducible (both in example and for new sheets) under Ubuntu 10.04 x86_64 running v4.1.3.2 Build ID: 70feb7d99726f064edab4605a8ab840c50ec57a.
Comment 3 QA Administrators 2015-04-19 03:23:47 UTC Comment hidden (obsolete)
Comment 4 Buovjaga 2015-06-19 14:59:39 UTC
Still repro.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 437210d58f32177ef1829d704f7f4d2f1bbfbfdd
TinderBox: Win-x86@39, Branch:master, Time: 2015-06-18_07:21:56
Locale: fi-FI (fi_FI)
Comment 5 sharkylaser 2016-02-04 11:38:49 UTC
Created attachment 122375 [details]
Floating point error when dragging a list to auto fill

Demonstrates deterioration of auto filled incremental lists. Possible floating point error.
Comment 6 sharkylaser 2016-02-04 11:40:53 UTC
Confirmed in 5.0.4.2

Attachment added.

Possible floating point error.
Comment 7 Xavier Van Wijmeersch 2017-09-17 09:50:42 UTC
Can not reproduce the error with, tested with both examples.

Version: 6.0.0.0.alpha0+
Build ID: 41b7713334351d7cc455eef5241bd3988b9d1e94
CPU threads: 8; OS: Linux 4.9; UI render: default; VCL: kde4; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-09-13_22:56:21
Locale: nl-BE (en_US.UTF-8); Calc: group
Comment 8 raal 2017-09-17 18:06:16 UTC
Tested with LO 6 on Linux and Windows and the bug is fixed. Closing.

dev version:
http://dev-builds.libreoffice.org/daily/master/