Download it now!
Bug 55964 - When sorting with data used in formulas, copies data rather than moves
Summary: When sorting with data used in formulas, copies data rather than moves
Status: RESOLVED DUPLICATE of bug 81309
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-14 06:44 UTC by werdnA
Modified: 2014-10-29 02:51 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Examples of Sorting data when refered to by other cells (13.54 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-10-14 06:44 UTC, werdnA
Details

Note You need to log in before you can comment on or make changes to this bug.
Description werdnA 2012-10-14 06:44:56 UTC
Created attachment 68547 [details]
Examples of Sorting data when refered to by other cells

When there are forulas relying on data from other source cells, and the source cells are sorted, the formulas dont reflect the new location of the original data. The only way to make it behave in a correct manner is to move the source data. Defeating the sort option.
IE
room	201		201	1	,49-52
name 	RM_201				
ports 	1,49-52				
interface 	1				
name 	RM_201				
room	202		202	2	,49-52
name 	RM_202				
ports 	2,49-52				
interface 	2				
name 	RM_202				
room	203		203	3	,49-52
name 	HSIA_RM203				
ports 	3,49-52				
interface 	3				
name 	HSIA_RM203				

Corectly sorted form:
room	201		201	1	,49-52
name 	RM_201		202	2	,49-52
ports 	1,49-52		203	3	,49-52
interface 	1				
name 	RM_201				
room	202				
name 	RM_202				
ports 	2,49-52				
interface 	2				
name 	RM_202				
room	203				
name 	RM_203				
ports 	3,49-52				
interface 	3				
name 	RM_203
Comment 1 A (Andy) 2013-03-02 21:42:33 UTC
reproducible with LO 4.0.0.3 (Win7 Home, 64bit)

(to get the result for the "Example Original form" several rows have to be inserted at the top of the sample file)
Comment 2 Jean-Baptiste Faure 2014-10-13 20:37:23 UTC
This case is solved by the fix of the bug 81309.
It works as expected in versions 4.3.4.0.0+ and 4.4.0 alpha (with the configuration option "Update references when sorting range of cells" checked.
Does not work in version 4.2.6.3 but should work in 4.2.7 because it contains the fix for bug 81309 too.

Set as duplicate of bug 81309.

Best regards. JBF

*** This bug has been marked as a duplicate of bug 81309 ***
Comment 3 Luke 2014-10-28 09:20:05 UTC
This is not a bug.ts work. This is how all spreadsheets work. To correctly sort a range that includes cells with references, all references must be absolute references. 

See this knowlege base article for further details:
http://support2.microsoft.com/kb/40401
Comment 4 Jean-Baptiste Faure 2014-10-28 22:00:04 UTC
(In reply to Luke from comment #3)
> This is not a bug.ts work. This is how all spreadsheets work. To correctly
> sort a range that includes cells with references, all references must be
> absolute references. 
> 
> See this knowlege base article for further details:
> http://support2.microsoft.com/kb/40401

For me, this article only proves that LibreOffice can be better than MS-Excel. If MS-Excel is not able to sort correctly this case, it is a defect in MS-Excel.

Best regards. JBF
Comment 5 stephanie park 2014-10-29 02:51:53 UTC
Jean-Baptiste Faure,
The definitions of relatives references and absolute references go all the way back VisiCalc. Just because the source of the definition is from Microsoft's knowledge base, doesn't make it any less valid. 

It is terribly unprofessional of FDO to ignore these facts and not revert the offending commits. They are causing real world data lost and loss of productivity for an imaginary use-case. So if you really care about being "better than MS-Excel" you should start by restoring the old functionality before you have no more users left.