Download it now!
Bug 55973 - [FORMATTING] Conditional formatting lost after database range is refreshed
Summary: [FORMATTING] Conditional formatting lost after database range is refreshed
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.3.1 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-14 14:59 UTC by spYre
Modified: 2013-10-03 03:42 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Spreadsheet document with sample database range based on Bibliography (11.61 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-10-14 14:59 UTC, spYre
Details

Note You need to log in before you can comment on or make changes to this bug.
Description spYre 2012-10-14 14:59:52 UTC
Created attachment 68551 [details]
Spreadsheet document with sample database range based on Bibliography

Test on Win 7 64bit.
Only reproducable with 3.6.3 rc1 release.

1. Create a database range based on a external database (I use Bibliography for the attached document)
2. Apply some conditonal formatting to the range
3. Refresh the range : menu Data -> Refresh range
4. CF is lost...
Comment 1 Michael Crouch 2012-11-12 18:10:54 UTC
I believe this is a duplicate of Bug 56764.

*** This bug has been marked as a duplicate of bug 56764 ***
Comment 2 spYre 2012-12-21 18:01:19 UTC
I don't see why this bug could be a duplicate of bug 56764.
Could someone give more details about this ?

Anyway, the bug described above is present from 3.6.3 rc1 to 4.0 beta.
Comment 3 spYre 2012-12-29 21:42:28 UTC
Sorry, but I just notice that this bug only happens when database range options "Insert or delete cells" AND "Keep formatting" are checked together.
When the first one is unchecked, conditional formatting is kept as expected.
Hope this will help.
Thank you all for your incredible job on LO, and have an happy new year !

(this time tested on LMDE 64bits)
Comment 4 spYre 2013-07-10 15:12:00 UTC
Bug seems to be fixed with LibO:
- Version: 4.1.0.2.0
- Build ID: 103a942746cfe346e87daab62acbd4268c38097

Thanks a lot, it was very annoying for an heavy use of database ranges !
And thanks for all the job within and around LibreOffice.
Comment 5 ign_christian 2013-10-03 03:42:39 UTC
WORKSFORME per comment 4. Please REOPENED if same problem reappear in future release.