Bug Hunting Session
Bug 55997 - sc_unoapi sc.ScModelObj::com::sun::star::sheet::XDocumentAuditing failure
Summary: sc_unoapi sc.ScModelObj::com::sun::star::sheet::XDocumentAuditing failure
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-15 13:01 UTC by Stephan Bergmann
Modified: 2015-02-02 15:57 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stephan Bergmann 2012-10-15 13:01:21 UTC
With recent master builds, sc_unoapi started to fail at

LOG> Log started 15.09.2012 - 14:03:31
checking: [sc.ScModelObj::com::sun::star::sheet::XDocumentAuditing] is iface: [com.sun.star.sheet.XDocumentAuditing] testcode: [ifc.sheet._XDocumentAuditing]
Shape Type: com.sun.star.drawing.LineShape
LOG> Execute: refreshArrows()
Shape Type: com.sun.star.drawing.LineShape
LOG> Arrow has been refreshed, but this should have been switched off.
Shape Type: com.sun.star.drawing.LineShape
Method refreshArrows() finished with state FAILED
LOG> refreshArrows(): PASSED.FAILED
***** State for sc.ScModelObj::com::sun::star::sheet::XDocumentAuditing ******
[sc.ScModelObj::com::sun::star::sheet::XDocumentAuditing::refreshArrows()] is testcode: [refreshArrows()] - PASSED.FAILED

as the call to setFormula in qadevOOo/tests/java/ifc/sheet/_XDocumentAuditing.java's _refreshArrows causes the arrow's getPosition to change slightly from p0.X=14111, p0.Y=2931 to p1.X=14111, p1.Y=2932.
Comment 1 Not Assigned 2012-10-15 13:06:53 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ed851f1316d34d1ecd60e75d04ed21b7bffdbf00

fdo#55997: Work around slight offset causing sc_unoapi failure



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 2 Joel Madero 2012-12-11 16:31:21 UTC
Stephan: Can this one be closed as FIXED with that patch?
Comment 3 Stephan Bergmann 2012-12-11 16:56:36 UTC
(In reply to comment #2)
> Stephan: Can this one be closed as FIXED with that patch?

No, see "This workaround should be removed again when there is a fix for the root cause." in <http://cgit.freedesktop.org/libreoffice/core/commit/?id=ed851f1316d34d1ecd60e75d04ed21b7bffdbf00>.
Comment 4 Michael Stahl (CIB) 2012-12-13 16:48:26 UTC
can confirm this one definitely failed here too :)
Comment 5 QA Administrators 2015-01-05 17:52:25 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.3.5 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
Comment 6 Stephan Bergmann 2015-02-02 15:57:07 UTC
<http://cgit.freedesktop.org/libreoffice/core/commit/?id=48f704c3e1c08ae6e3eee450bf08712dc4caf460>:

"Revert 'fdo#55997: Work around slight offset causing sc_unoapi failure'

This reverts commit ed851f1316d34d1ecd60e75d04ed21b7bffdbf00, the underlying
problem causing JunitTest_sc_unoapi's

> checking: [sc.ScModelObj::com::sun::star::sheet::XDocumentAuditing] is iface [com.sun.star.sheet.XDocumentAuditing] testcode: [ifc.sheet._XDocumentAuditing]
> Shape Type: com.sun.star.drawing.LineShape
> LOG> Execute: refreshArrows()
> Shape Type: com.sun.star.drawing.LineShape
> Shape Type: com.sun.star.drawing.LineShape
> Method refreshArrows() finished with state OK

to fail appears to be fixed meanwhile."