Bug 56000 - FILESAVE: save icon should just stay active always
Summary: FILESAVE: save icon should just stay active always
Status: RESOLVED DUPLICATE of bug 61060
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.1.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-15 13:27 UTC by John
Modified: 2013-03-03 15:45 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John 2012-10-15 13:27:34 UTC
when i'm working with the Calc program i noticed that the developers went with the interactive save icon approach.. the problem is, perhaps only in a spreadsheet, there are things that i can change that may not trigger the icon to be enabled again after i have saved.

example: 
i may freeze a portion of the window after my last save, and that action will not trigger the save button to become enabled again.


i think having an interactive save icon is cool, but when compared to the potential for bugs such as this, and the extra coding i'm sure had to be done to keep up with possible triggers to re-enable the button, i think just leaving the icon always enabled is the better more sensible option. it's on the user to keep up with whether or not they saved their work. when applications try to think for you, that's when things start getting weird. not being able to save after i just froze a portion of the spreadsheet is weird.
Comment 1 A (Andy) 2013-03-02 21:57:35 UTC
I would wish to keep this interactive save icon approach.  
But if you freeze the window, then of course the save button should be activated (reproducible with LO 4.0.0.3 (Win7 Home, 64bit)).
Comment 2 Urmas 2013-03-03 15:45:30 UTC

*** This bug has been marked as a duplicate of bug 61060 ***