Download it now!
Bug 56068 - EDITING: Paste Special for copy of cell with formula unavailable, only plain text pasted
Summary: EDITING: Paste Special for copy of cell with formula unavailable, only plain ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.3.1 rc
Hardware: Other Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-17 06:59 UTC by Rainer Bielefeld Retired
Modified: 2013-03-20 06:02 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-10-17 06:59:19 UTC
With  "LibreOffice 3.6.3.1” German UI/ German Locale [Build-ID: f8fce0b] on German WIN7 Home Premium (64bit) I currently observe very often that when I copy a single cell with a simple formula contents like "=E15*$G$13" only the result of the calculation as  plain text will be pasted, and 'Paste Special' is not available.

Unfortunately I currently do not know how to make that reproducible, sometimes it works, sometimes it does not work. I will do further research. 

Anybody who can confirm that problem (and may be has a solution how to make that reproducible?
Comment 1 Michael Meeks 2012-12-10 20:50:06 UTC
Rainer - trying to reproduce: can you expand ? Are you copy/pasting on the same sheet ? are you using keystrokes to do that ? does it depend if you paste the formula above and to the left of the original cell vs. below and right ? How would you trigger Paste Special ? ctrl-shift-v or somesuch ? [ and it just pastes, rather than showing the dialog ? ].

Thanks ! :-)
Comment 2 Rainer Bielefeld Retired 2012-12-13 15:51:11 UTC
This single user problem seems not to be a MAB.

@Michael:
Unfortunately I can't narrow down the problem. I see that for copying from any source (Same sheet, other Spreadsheet document, Web page table, Web page formatted text with hyperlink, anything else), in any way (control+v, context menu, mouse button). The symptom I see afterwards is that only "Unformatted Text" is available at paste icon in standard toolbar, so the (LibO?-) clipboard contents only is plain text. I never saw such a problem in Writer, but I think I copy 100 times more to Calc than to Writer. 

I even can't be sure that it really is a LibO problem, because I do not copy so much with other software, so may be the problem also exists for other programs, but only appears 1x in a year?

Sometimes it happens several times a day, or if I am lucky I have a week without that problem. 

So I still am hoping for a "brainwave".
Comment 3 Rainer Bielefeld Retired 2013-01-28 12:51:51 UTC
I wonder whether this problem might be related to running TightVNC Viewer
Comment 4 Rainer Bielefeld Retired 2013-03-20 06:02:16 UTC
I have lots of documents damaged by this bug with lots of missing formulas in cells, but since several weeks I have not been able to reproduce this problem. so WFM for now.