Bug 56178 - monochrome TIFF not rendered correctly
Summary: monochrome TIFF not rendered correctly
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
(earliest affected)
3.5.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
Depends on:
Blocks: Images-TIFF
  Show dependency treegraph
Reported: 2012-10-19 12:35 UTC by stfhell
Modified: 2019-06-28 19:11 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:

Attached: TIFF image (9.24 KB, image/tiff)
2012-10-19 12:35 UTC, stfhell
a bt at the moment bStatus gets sal_False (5.08 KB, text/plain)
2014-02-01 17:58 UTC, Julien Nabet
TIFF image loaded in Writer 5.0.0 RC3 (4.70 KB, image/png)
2015-07-19 09:08 UTC, Stanislav Horacek

Note You need to log in before you can comment on or make changes to this bug.
Description stfhell 2012-10-19 12:35:00 UTC
Created attachment 68796 [details]
Attached: TIFF image

LibreOffice/Linux is not able to insert the attached TIFF image in a Writer or Impress document. Error message: "Unknown graphic format".

The TIFF is a 1-bit Group-4-compressed TIFF image produced with GIMP. tiffinfo says:

TIFF Directory at offset 0x2f1c (12060)
  Subfile Type: (0 = 0x0)
  Image Width: 3156 Image Length: 1844
  Resolution: 600, 600 pixels/inch
  Bits/Sample: 1
  Compression Scheme: CCITT Group 4
  Photometric Interpretation: min-is-white
  Orientation: row 0 top, col 0 lhs
  Samples/Pixel: 1
  Rows/Strip: 64
  Planar Configuration: single image plane

Tested with LO and under Ubuntu 12.04 (64 and 32 bit).

Other 1-bit TIFFs work, for example one written by ImageMagick with tiffinfo
TIFF Directory at offset 0x42fa (17146)
  Image Width: 500 Image Length: 375
  Resolution: 72, 72 pixels/inch
  Bits/Sample: 1
  Compression Scheme: CCITT Group 4
  Photometric Interpretation: min-is-white
  FillOrder: msb-to-lsb
  Orientation: row 0 top, col 0 lhs
  Samples/Pixel: 1
  Rows/Strip: 375
  Planar Configuration: single image plane
  Page Number: 0-1
Comment 1 bfoman (inactive) 2013-05-08 13:29:00 UTC
Confirmed with:
Build ID: own W7 debug build
Windows 7 Professional SP1 64 bit

Error message: "Unknown graphic format". File is viewable and can be inserted in Word or Powerpoint 2010.
Comment 2 Bernhard Rohrer 2013-05-08 23:23:03 UTC
confirmed in Linux
Comment 3 Julien Nabet 2014-02-01 17:58:40 UTC
Created attachment 93187 [details]
a bt at the moment bStatus gets sal_False

Bt retrieved on pc Debian x86-64 with master sources updated yesterday
Comment 4 Julien Nabet 2014-02-01 18:01:18 UTC
Caolán: I runned a gdb session and retrieved a backtrace with master sources updated yesterday. Any idea what is wrong here?
The tiff can be read with Doc displayer (Debian testing)
Comment 5 Caolán McNamara 2014-02-07 16:09:23 UTC
There's a gadzillion tiff extensions and features and we don't implement them all (yet). I'd *guess* we haven't implemented CCITT Group 4 compression.
Comment 6 LE GARREC Vincent 2014-07-02 09:09:43 UTC
Is it me or this feature have been implemented in LO ? I tried and LO succeed to load a Group 4 TIF. There's small issue with the rendering but no critical failure.
Comment 7 LE GARREC Vincent 2014-07-02 09:23:30 UTC
Sorry for the noise. The image that I tested worked quite well with Group 4 attribute but the original enclosed image still unreadable.
Comment 8 QA Administrators 2015-07-18 17:44:25 UTC Comment hidden (obsolete)
Comment 9 Stanislav Horacek 2015-07-19 09:08:09 UTC
Created attachment 117329 [details]
TIFF image loaded in Writer 5.0.0 RC3
Comment 10 Stanislav Horacek 2015-07-19 09:10:18 UTC
Now there is no error message and the TIFF is loaded, however it is still not rendered correctly - see the screenshot from Writer.

Tested in 4.4.2, 5.0.0 RC3 and recent master with the same result (OS: Kubuntu 15.04).
Comment 11 QA Administrators 2016-09-20 10:18:34 UTC Comment hidden (obsolete)
Comment 12 Stanislav Horacek 2016-09-22 18:59:38 UTC
The same behaviour as above - the image is loaded, but rendered incorrectly - observed in 5.2.1 and current master (Kubuntu 16.04).
Comment 13 Telesto 2016-11-18 14:47:36 UTC
Confirmed with:
Build ID: b223028d65d24ffcd8e27974c29c2744a5df6227
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; Layout Engine: new; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-11-16_22:50:22
Locale: nl-NL (nl_NL); Calc: CL

When drag & drop & with Insert --> Image.
It works when I open c.q copy the image from IrfanView and paste it in Writer.
Comment 14 QA Administrators 2017-11-19 19:14:32 UTC Comment hidden (obsolete)
Comment 15 Stanislav Horacek 2017-11-21 18:41:47 UTC
The incorrect rendering of the image persists in: Version:
Build ID: 141fe1c5e7fbf67a083b34e49e19b6ea78a0eb2b