Bug 56326 - BUGZILLAASSISTANT: Can't Update BSA Since Wiki Upgrade
Summary: BUGZILLAASSISTANT: Can't Update BSA Since Wiki Upgrade
Status: RESOLVED DUPLICATE of bug 56312
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: WWW (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-23 15:06 UTC by Joel Madero
Modified: 2012-10-23 21:47 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joel Madero 2012-10-23 15:06:26 UTC
Problem description: 

Make of BSA no longer works. Problem has existed since upgrade of wiki. This is the output:

Current branch master is up to date.
mkdir -p build
curl --silent http://wiki.documentfoundation.org/BugReport_Details | tidy --numeric-entities yes -asxhtml 2>/dev/null | perl -pe 's|xmlns="http://www.w3.org/1999/xhtml"||' > build/BugReport_Details.xhtml
xsltproc --encoding UTF-8 --novalid component_comments.xsl build/BugReport_Details.xhtml > build/component_comments.xhtml
xsltproc --encoding UTF-8 --novalid subcomponents.xsl build/BugReport_Details.xhtml > build/subcomponents.xhtml
xsltproc --encoding UTF-8 --novalid components.xsl build/BugReport_Details.xhtml > build/components.xhtml
curl --silent 'https://bugs.freedesktop.org/query.cgi?product=LibreOffice&query_format=advanced' > build/query.xhtml
perl query.pl < build/query.xhtml > build/versions.xhtml
perl sanity.pl build/query.xhtml build/components.xhtml
component Writer found in bugzilla but not in the wiki
component Drawing found in bugzilla but not in the wiki
component UI found in bugzilla but not in the wiki
component Printing and PDF export found in bugzilla but not in the wiki
component Installation found in bugzilla but not in the wiki
component Formula Editor found in bugzilla but not in the wiki
component Extensions found in bugzilla but not in the wiki
component Database found in bugzilla but not in the wiki
component Linguistic found in bugzilla but not in the wiki
component Chart found in bugzilla but not in the wiki
component Localization found in bugzilla but not in the wiki
component Documentation found in bugzilla but not in the wiki
component Presentation found in bugzilla but not in the wiki
component WWW found in bugzilla but not in the wiki
component BASIC found in bugzilla but not in the wiki
component Spreadsheet found in bugzilla but not in the wiki
component Libreoffice found in bugzilla but not in the wiki
wiki URL http://wiki.documentfoundation.org/BugReport_Details
components extracted with components.xsl from the wiki are in build/components.xhtml
bugzilla URL https://bugassistant.libreoffice.org/enter_bug.cgi?product=LibreOffice
bugzilla information retrieved from build/query.xhtml
make: *** [extract] Error 17


Steps to reproduce:
1. If you have permissions, try to make BSA website

Current behavior:
Error listed above

Expected behavior:
No error, should make no problem. Without this we can't update BSA at all

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (X11; Bodhi; Linux x86_64; rv:16.0) Gecko/20100101 Firefox/16.0
Comment 1 Joel Madero 2012-10-23 15:10:38 UTC
I added a few people to CC who have been involved with the discussion. This has to be a high priority fix, just not sure who can fix it. According to Christian it's an easy fix so maybe it'd only a few minutes to edit whatever needs to be changed.

If someone has a recommendation of who can fix this please let me know or add them to CC. It's been over a week and we haven't been able to touch BSA. 

Thanks all

Also, marking as NEW as it's been confirmed by at least 3 people
Comment 2 Rainer Bielefeld Retired 2012-10-23 15:15:08 UTC
redundancy always is a good thing, but why not simply use the existing "Bug 56326 - BUGZILLAASSISTANT: Can't Update BSA Since Wiki Upgrade"? ;-)
Comment 3 Joel Madero 2012-10-23 15:43:09 UTC
My bad, that's what I get for not checking if it's already been reported ;)
Comment 4 Joel Madero 2012-10-23 15:44:11 UTC
Wait, that's the same bug ;) Where is redundancy?
Comment 5 Rob Snelders 2012-10-23 21:47:05 UTC

*** This bug has been marked as a duplicate of bug 56312 ***