Bug 56409 - Scrolling problems on large file: cannot scroll up, display mangled.
Summary: Scrolling problems on large file: cannot scroll up, display mangled.
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.2.2 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL: http://docsonline.wto.org/imrd/direct...
Whiteboard:
Keywords:
Depends on:
Blocks: Scrolling-PageUpDown
  Show dependency treegraph
 
Reported: 2012-10-25 18:29 UTC by lupo.bugzilla
Modified: 2019-11-02 15:23 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Screen shot showing the problem in step 8 (284.03 KB, image/png)
2012-10-25 18:29 UTC, lupo.bugzilla
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lupo.bugzilla 2012-10-25 18:29:31 UTC
Created attachment 69088 [details]
Screen shot showing the problem in step 8

On the 5.3MB, 616page file at the URL specified, Writer has multiple severe problems:

1. Until the first page is displayed, Writer takes about 30seconds at 100% CPU. This is on a normally very performant iMac (3.1GHz i5, 8GB RAM, OS X 10.7.5).
 
2. After that first page is finally displayed, Writer spends another 40sec at 100% CPU, even if the user does absolutely nothing. After that, CPU usage drops to 0.3% (but not to zero).

Note: OpenOffice 3.4.1 does a little bit better. It takes about 20sec at 98% CPU to display the first page, but then CPU usage drops to 0.1% immediately.

3. Now move the mouse pointer to the scroll bar, grab the slider and start sliding it down.

4. Scroll to the middle of the document; do not release the slider yet. Move the slider up and down: works. Now release the slider.

5. Grab the slider again and try to scroll up: doesn't work. You can only scroll down.

6. Interestingly, you can scroll up using the mouse wheel.

7. Hit the "home" button. The first page of the document is displayed. Repeat steps 3-5 with the same results.

Note: this scrolling problem also exists in OpenOffice 3.4.1.

8. Hit the "home" button again. Scroll down beyond the table of contents, click into a header on a page. Then scroll around using the scroll bar. The blue header indicators start to accumulate on the display. See attached screenshot.
Comment 1 Emir Sarı 2012-11-23 03:03:23 UTC
I can confirm this issue on OS X 10.7.5. 

I also had such a file, had display issues with Header/Footer UI, and CPU immediately hits 100% after opening the file.

Since it is a confidental file, I cannot attach here, but I can assure that this bug is valid. 

Setting status to NEW.
Comment 2 QA Administrators 2015-01-05 17:51:24 UTC Comment hidden (obsolete)
Comment 3 lupo.bugzilla 2015-01-07 22:08:15 UTC
(In reply to QA Administrators from comment #2)

Bug is still present in LibreOffice 4.3.5; OS X 10.7.5.

Bug details have changed, though: steps 3-7 are no longer valid; that part of the problem appears to have been fixed.

However, steps 1 and 2 are still a problem and still take about 30 and 40 secs each, and the accumulation of blue header indicators in step 8 (see screenshot attached to original report) still occurs.
Comment 4 QA Administrators 2016-01-17 20:02:41 UTC Comment hidden (obsolete)
Comment 5 QA Administrators 2017-03-06 13:56:56 UTC Comment hidden (obsolete)
Comment 6 eisa01 2017-08-26 18:01:31 UTC
LibreOffice is still slow on step 1 and 2, although I'm not sure this is a Mac only problem, and it's unrelated to the scrolling bugs.

Word 2016 is better in that it does show the document almost immediately, but loads it in page by page instead

For step 8 I can replicate the problem:
1. Click in a header
2. Drag the scroll bar quickly up and down
3. See the header dividers show up all over the screen
4. Click elsewhere in the document to have it disappear again
Comment 7 QA Administrators 2018-09-03 02:42:30 UTC Comment hidden (obsolete)
Comment 8 Timur 2018-09-03 08:41:33 UTC
This bug is not valid without example document.
Comment 9 lupo.bugzilla 2018-09-03 21:15:40 UTC
See the URL given above and mentioned in comment 0. That URL still works, even after 6 years: http://docsonline.wto.org/imrd/directdoc.asp?DDFDocuments/t/WT/min11/2.doc

State is unchanged from comment 3. Problems persist in LibreOffice 6.0.6 on OS X 10.12.6.

1. Until the first page is displayed, Writer takes about 30 seconds at nearly 100% CPU.

2. After that first page is finally displayed, Writer spends another 40sec at nearly 100% CPU, even if the user does absolutely nothing. After that, CPU usage drops to 0%.

(Original steps 3-7 from comment 0 appear to be fixed.)

3. (Original step 8 from comment 0): Scroll down beyond the table of contents, click into a header on a page. Then scroll around using the scroll bar. The blue header indicators start to accumulate on the display. See attached screenshot.

Version info:

Version: 6.0.6.2
Build ID: 0c292870b25a325b5ed35f6b45599d2ea4458e77
CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; 
Locale: en-US (en_CH.UTF-8); Calc: group
Comment 10 QA Administrators 2019-09-04 04:29:27 UTC Comment hidden (obsolete)
Comment 11 eisa01 2019-11-02 15:23:39 UTC
So I no longer see the header distortions in step 8

I have also gotten a new Mac (MBP 2015 13"), and the document is not as slow any more given its size

Setting this as resolved

Version: 6.4.0.0.alpha1+
Build ID: 80109586e6cb6d3e2e0a53a9079c3125ec9b8368
CPU threads: 4; OS: Mac OS X 10.14.6; UI render: default; VCL: osx; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded