Download it now!
Bug 56522 - Sorting without table headlines
Summary: Sorting without table headlines
Status: RESOLVED DUPLICATE of bug 53482
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.3.2 release
Hardware: Other Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-29 13:34 UTC by juergen.geisler
Modified: 2014-10-12 20:22 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
simple spreadsheet for test of sorting (7.70 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-10-29 13:34 UTC, juergen.geisler
Details

Note You need to log in before you can comment on or make changes to this bug.
Description juergen.geisler 2012-10-29 13:34:07 UTC
Created attachment 69228 [details]
simple spreadsheet for test of sorting

Tablesorting: Option "selected area contains column titles" does not work. The sorting includes the first line.
Comment 1 Regina Henschel 2012-10-30 14:49:02 UTC
I have no problem with sorting. Please describe step by step, what you are doing.
My way:
1. Select the data including the column title cells.
2. Data > Sort > Tab Options. Make sure "Range contains column labels" is checked.
3. Tab "Sort criteria". Make sure the drop-down field shows the correct label.
4. Choose sort direction. OK.
Comment 2 juergen.geisler 2012-11-05 08:32:16 UTC
Dear Regina Henschel,

thanks for your message. The problem is still existing. But I detected 
the difference between your way and my way:

When I select either only the fields of the region to sort or at least 
only the columns where the data to sort is in, everything works fine.

But when I select all (/ctrl a/) or at least one empty column 
additionally to the columns where my data is in, the option "/Range 
contains column labels/" is without effect.

But this worked (as I remember, because I work with /LibreOffice /since 
it exists) with former versions. And it works with Microsoft Excel!

With the hope that you can help
kind regards from Karlsruhe
Jürgen Geisler


Am 30.10.2012 15:49, schrieb bugzilla-daemon@freedesktop.org:
> Regina Henschel <mailto:rb.henschel@t-online.de> changed bug 56522 
> <https://bugs.freedesktop.org/show_bug.cgi?id=56522>
> What 	Removed 	Added
> CC 		rb.henschel@t-online.de
> Keywords 		NEEDINFO
>
> *Comment # 1 <https://bugs.freedesktop.org/show_bug.cgi?id=56522#c1> 
> on bug 56522 <https://bugs.freedesktop.org/show_bug.cgi?id=56522> from 
> Regina Henschel <mailto:rb.henschel@t-online.de> *
> I have no problem with sorting. Please describe step by step, what you are
> doing.
> My way:
> 1. Select the data including the column title cells.
> 2. Data > Sort > Tab Options. Make sure "Range contains column labels" is
> checked.
> 3. Tab "Sort criteria". Make sure the drop-down field shows the correct label.
> 4. Choose sort direction. OK.
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You reported the bug.
>
Comment 3 QA Administrators 2013-07-18 06:15:59 UTC
Dear Bug Submitter,

Please read the entire message in its entirety before continuing - also please respond directly to FDO when replying - do not reply via email.

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 4 QA Administrators 2013-09-24 02:06:25 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INVALID due to inactivity and a lack of information which is needed in order to accurately reproduce and confirm the problem. We encourage you to retest your bug against the latest release. If the issue is still present in the latest stable release, we need the following information (please ignore any that you've already provided):

a) Provide details of your system including your operating system and the latest version of LibreOffice that you have confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED and we will attempt to reproduce the issue. 
Please do not:
a) respond via email 
b) update the version field in the bug or any of the other details on the top section of FDO
Comment 5 Jean-Baptiste Faure 2014-10-12 20:22:35 UTC

*** This bug has been marked as a duplicate of bug 53482 ***