Download it now!
Bug 56539 - Automatic Figure, Table and Equation numbers from MS Office 2010 (docx) not present in document opened by Writer
Summary: Automatic Figure, Table and Equation numbers from MS Office 2010 (docx) not p...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 57791 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-10-29 20:17 UTC by D. Charlie Curcija
Modified: 2015-06-11 18:17 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Attached file contains original MS Word numbering, which does not show in Writer (191.26 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2012-10-29 20:17 UTC, D. Charlie Curcija
Details

Note You need to log in before you can comment on or make changes to this bug.
Description D. Charlie Curcija 2012-10-29 20:17:08 UTC
Created attachment 69250 [details]
Attached file contains original MS Word numbering, which does not show in Writer

When opening MS Office 2010 word document (docx) in Writer, all automatic numbering for Figure, Table and Equation numbers are blank.  Numbering in MS Word was created using Reference and Cross-Reference feature and has been the standard way to do automated numbering in Word for several versions now.  The document was created and edited in MS Word 32, running on Windows 7 64 bit machine (32 bit version of Office is generally recommended by Microsoft)

Original docx file attached for your verification.
Comment 1 A (Andy) 2012-12-24 16:13:15 UTC
reproducible and confirmed with LO 3.6.4.3. (Win7 Home, 64bit)

All numbering for figures and equations are missing.  If you open the same file in Word 2007 everything is fine.  

In addition, I recognized two further bugs.  
First, the images and text in the header and footer are grey in the original Word document (opened in Word 2007), but in LO they are black.
Second, in the orginal document the page numbering in the header is aligned right, but in LO this is missed and the page numbering is following right after the header text.
Comment 2 Jan Kundrát 2013-03-11 10:55:43 UTC
I can reproduce that with 3.6.4.3 on Linux (Gentoo's prebuilt binary package), both with the attached file and some other real-world files as well.

The annoying part is that this numbering is not preserved after a save, so it's effectively a case of a (minor) data loss.
Comment 3 Adam CloudOn 2013-06-11 07:46:06 UTC
Apprently the 'Figure Number' in the caption was fixed in master.
Comment 4 Jorendc 2013-12-28 23:41:45 UTC
*** Bug 57791 has been marked as a duplicate of this bug. ***
Comment 5 Jorendc 2013-12-28 23:46:28 UTC
(In reply to comment #3)
> Apprently the 'Figure Number' in the caption was fixed in master.

Failed to reproduce that. (see Bug 71310). When I roundtrip attachment 80191 [details] (open using LibreOffice, re-save it as .docx with different name, reopen it with LibreOffice) the number is generated first correctly. Right after that (repainting) it result in a wrong caption number. See mentioned bug for more details.

At least, the behavior is improved :-)!
Comment 6 QA Administrators 2015-04-19 03:21:48 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-18
Comment 7 Gordo 2015-06-11 18:17:25 UTC
Could not reproduce.

Version: 4.4.3.2
Build ID: 88805f81e9fe61362df02b9941de8e38a9b5fd16

4.1.6.2

Changed to RESOLVED WORKSFORME.