Bug 57791 - Caption numbering lost when saving to .docx
Summary: Caption numbering lost when saving to .docx
Status: RESOLVED DUPLICATE of bug 56539
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-02 00:51 UTC by Dominik
Modified: 2013-12-28 23:41 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominik 2012-12-02 00:51:52 UTC
in the client file the numbering works as expected (when a caption to an image is added), but in the master document there's just a blank instead of the number
Comment 1 Jorendc 2012-12-27 21:55:11 UTC
Thanks for reporting!

Can reproduce this on Mac OS X 10.8.2. (-> not Windows only, so set platforms to 'all')

I changed the bug title from "automatic image numbering broken (master document)" to "Caption numbering lost when saving to .docx"

As title suggest, I can't reproduce this bug when saving to .odt.

How to reproduce:
* open new writer document
* insert image (Insert -> Picture -> From file...)
* select image
* right click -> Caption ...
* Use default settings: Category 'Illustration', Numbering 'Arabic', Seperator ':'
* OK. Now there is text under the image 'Illustration 1'
* File -> Save as ...
* Save document as .docx
* Close and reopen document

Current behavior: Lost caption numbering (only text 'Illustration')

Expected behavior: numbering still there after saving as .docx
Comment 2 Jorendc 2013-12-28 23:41:45 UTC
Dupe of 56539 and 65285

*** This bug has been marked as a duplicate of bug 56539 ***