Download it now!
Bug 56588 - EDITING: Sort with headers sorts the header if the primary sort key is text
Summary: EDITING: Sort with headers sorts the header if the primary sort key is text
Status: RESOLVED DUPLICATE of bug 53482
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.2.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-30 16:29 UTC by MR Zenwiz
Modified: 2012-11-03 12:29 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description MR Zenwiz 2012-10-30 16:29:33 UTC
Problem description: 
I have spreadsheets for tracking expenses that include a column for categorizing the expense.  If I sort the sheet with that column as the primary key and select the "Range contains column labels" option, the column label row gets sorted in with the rest, putting it elsewhere than at the top row.

Steps to reproduce:
1. Create a spreadsheet with column labels, including a date, a "what" column and other columns that contain currency cells.
2. Fill in some rows with dates, a category and dollar amounts, not all of which are filled in (typically one column per row).
3. Sort using the "what" column as the primary key and one or two other columns as secondary (and below) keys.

Current behavior:
The label row will be sorted in alphabetical order by the contents of the "what" column, not left at the top.

Expected behavior:
The header row should never be moved from the top row.

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:16.0) Gecko/20100101 Firefox/16.0
Comment 1 Jean-Baptiste Faure 2012-11-03 12:29:59 UTC
Duplicate of bug 53482 fixed in LO 3.6.3.

Please upgrade to the current version and try again.

Best regards. JBF

*** This bug has been marked as a duplicate of bug 53482 ***