Download it now!
Bug 56650 - FILEOPEN: hyperlink to other documents cell restores wrong path
Summary: FILEOPEN: hyperlink to other documents cell restores wrong path
Status: RESOLVED DUPLICATE of bug 48463
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: All Linux (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-01 23:06 UTC by Martin Koller
Modified: 2013-06-13 02:10 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Koller 2012-11-01 23:06:46 UTC
Problem description: 

I have one document first.xls and another one second.xls

When I have a cell in second.xls with a reference to first.xls like
='file:///tmp/doc/first.xls'#$Sheet1.B2

the path to the file is always doubled when I open second.xls again. So after reopening second.xls I get the path as:
='file:///tmp/doc/tmp/doc/first.xls'#$Sheet1.B2

This does not happen when I save the "second" document in .ods format.

Platform (if different from the browser): 

openSuse 12.1, 32bit
              
Browser: Mozilla/5.0 (X11; U; i686 Linux; en_US, de; rv:1.9.2) Gecko/20100115 Firefox/3.6
Comment 1 A (Andy) 2012-12-24 18:16:07 UTC
not reproducible with LO 3.6.4.3. (Win7 Home, 64bit)
Comment 2 Martin Koller 2013-02-15 19:09:58 UTC
I can still reproduce this problem with 4.0.0.3 on Linux openSuse 12.2/64 bit
Comment 3 Joel Madero 2013-02-19 21:56:29 UTC
I can reproduce this in 3.6.4.3 on Bodhi Linux 2.2

Updating version to reflect this as version is the oldest version that we can confirm the problem on.

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Marking as:
New (confirmed)
Major (loss of data, quite a pain when referencing across different documents)
High (default for major bugs, think that it fits here, could affect quite a few users)
Comment 4 Goran Rakic 2013-06-13 02:01:05 UTC
The bug shows only if the spreadsheet is saved as XLS. There is no error when using ODF. Reproducable in LibreOffice 4.0.3 on Linux.

Steps to reproduce:
1) Create or open any spreadsheet
2) Create a new spreadsheet and link some cells to the first one
3) Save the new spreadsheet as XLS
4) Re-open this XLS spreadsheet.

The file path up to the filename in the link is repeated twice.
Comment 5 Goran Rakic 2013-06-13 02:10:22 UTC

*** This bug has been marked as a duplicate of bug 48463 ***