Bug 56717 - sorting data in the spreadsheet is not as good as excel
Summary: sorting data in the spreadsheet is not as good as excel
Status: RESOLVED DUPLICATE of bug 53482
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-03 14:48 UTC by Anand Kumria
Modified: 2012-12-01 13:53 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anand Kumria 2012-11-03 14:48:34 UTC
I am following along the Coursera courge (Computation Investing).

They grab data for a specific month range for a stock (AAPL from finance.yahoo.com) and download it as a CSV.

The data is then sorted.

In Excel; you select the entire spreadsheet, hit the sort menu item and are prompted to pick the column (with the title, e.g. Date, etc, in it) and the data is sorted -- and the row which has columns in it is *NOT* moved.

In LibreOffice; you select the entire spreadsheet, hit the sort menu item and have to pick the column (named as Column A, B, etc.) and the data is sorted.

However the row which has the column title is also sorted.

It would be an improvement if sorting worked as people expect -- not moving the title row.
Comment 1 m.a.riosv 2012-11-21 22:07:14 UTC
In Menu/Data/Sort/Options, you can set: Range contains column labels
Comment 2 Julien Nabet 2012-12-01 13:53:04 UTC
Anand: You should give a try to 3.6.3 which contains a fix about this.
If you reproduce this with this 3.6.3, don't hesitate to reopen the tracker, include your file and give a step by step to reproduce the behaviour.

*** This bug has been marked as a duplicate of bug 53482 ***