Bug Hunting Session
Bug 56760 - FILESAVE: docx file save picture position problem
Summary: FILESAVE: docx file save picture position problem
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.3.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA (target:4.1.4)
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-05 09:13 UTC by Václav Dort
Modified: 2013-12-29 00:10 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Document for testing change picture position. (51.43 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2012-11-05 09:13 UTC, Václav Dort
Details
image load error after saving a docx file as docx in Libreoffice (5.32 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-01-08 16:02 UTC, Oliver
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Václav Dort 2012-11-05 09:13:37 UTC
Created attachment 69547 [details]
Document for testing change picture position.

Problem description: 

docx file save picture position problem

Steps to reproduce:
1. Open attached file (from Microsof Office)
2. Save in same format (docx) with another name
3. Open saved file
4. Picture onte left side change position.

When is document opened and saved in doc or odt format, everythink OK, Problem is only in docx.

Thanks

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_2) AppleWebKit/536.26.17 (KHTML, like Gecko) Version/6.0.2 Safari/536.26.17
Comment 1 Jorendc 2012-12-15 09:44:44 UTC
Thanks for reporting this bug.

How did you insert the image in that document? By 'Paste Special' or 'Past' (normally as cmd+v) from your Firefox (I see you use firefox)? If yes, what firefox version?

I'm asking this, because this could be related to bug fdo#52547

I can confirm this behavior with LO Version 4.0.0.0.beta1 (Build-id: 87906242e87d3ddb2ba9827818f2d1416d80cc7)
TinderBox: MacOSX TDF Release, Branch:libreoffice-4-0, Time: 2012-12-05_22:13:37;
Mac OSX 10.8.2
Comment 3 Oliver 2013-01-08 16:00:40 UTC
I have observed a very similar behaviour : in the versions before 3.6.4.3 when opening a docx document edited in microsoft word that contains positionned images, then upon saving as docx in Libreoffice and reopening in Libreoffice all images would be positionned at the start of the document (one after the other or on top of each other). 
however this now changed in version 3.6.4.3 : now, after saving as docx and reopening, the images are in the correct position, but cannot be loaded anymore : one gets just empty boxes (see attached file)

Cheers

Oliver
Comment 4 Oliver 2013-01-08 16:02:39 UTC
Created attachment 72682 [details]
image load error after saving a docx file as docx in Libreoffice

This file shows what happens when a docx file edited in MSWord is opened in Libreoffice, saved as docx, and the reopened -> inserted images cannot be loaded anymore
Comment 5 Timur 2013-05-16 08:18:30 UTC
Please take a look at the earlier Bug 37315 - pictures in docx file appears in wrong place and see whether this one could be marked as it's duplicate.
Comment 6 Timur 2013-05-16 08:22:34 UTC
(In reply to comment #4)
> Created attachment 72682 [details]
> image load error after saving a docx file as docx in Libreoffice
> 
> This file shows what happens when a docx file edited in MSWord is opened in
> Libreoffice, saved as docx, and the reopened -> inserted images cannot be
> loaded anymore

There are many bugs on this issue: Bug 46547, Bug 52226, Bug 43641 .. At least Bug 52226 is on MAB 4.0. now.
Comment 7 Jorendc 2013-12-29 00:10:48 UTC
Can't reproduce this bug anymore, with provided attachment 69547 [details].

Tested using Windows 8.1 with LibreOffice Version: 4.3.0.0.alpha0+
Build ID: 5be7ec4193b892e5643ff5f3f2e6755319569190
TinderBox: Win-x86@39, Branch:master, Time: 2013-12-27_23:55:02

Also NOT reproducible with Version: 4.1.4.2
Build ID: 0a0440ccc0227ad9829de5f46be37cfb6edcf72

If this document have still issues, please verify with other mentioned bugs in this report first (see comment 6), and if it's not reported already, please create a new bug report.

Kind regards,
Joren