Bug Hunting Session
Bug 56766 - SLIDESHOW: Gradient for Data Series not shown in CHART without transparency
Summary: SLIDESHOW: Gradient for Data Series not shown in CHART without transparency
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: Other All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: BSA (target:4.0.0)
Keywords:
: 57238 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-11-05 11:16 UTC by bugquestcontri
Modified: 2013-06-14 14:08 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of Calc chart pasted as GDIMetafile in NormalView (26.90 KB, image/gif)
2012-11-05 11:16 UTC, bugquestcontri
Details
Screenshot of Calc chart pasted as GDIMetafile in Slide Show View (41.45 KB, image/gif)
2012-11-05 11:17 UTC, bugquestcontri
Details
Screenshot of Calc chart pasted as Star Object in NormalView (31.49 KB, image/gif)
2012-11-05 11:18 UTC, bugquestcontri
Details
Screenshot of Calc chart pasted as Star object in Slide Show View (28.01 KB, image/gif)
2012-11-05 11:19 UTC, bugquestcontri
Details
Impress sample (111.15 KB, application/vnd.oasis.opendocument.presentation)
2012-11-26 14:06 UTC, bugquestcontri
Details
another Impress file with sample slides and explanations (34.91 KB, application/vnd.oasis.opendocument.presentation)
2012-11-27 07:33 UTC, bugquestcontri
Details
Test kit with source document (28.74 KB, application/x-zip-compressed)
2012-11-27 08:23 UTC, Rainer Bielefeld Retired
Details
Orignal Calc file with original charts (37.86 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-11-28 00:44 UTC, bugquestcontri
Details
slide where I observed difference between normal view and slide show for the first time (74.56 KB, application/vnd.oasis.opendocument.presentation)
2012-11-28 01:36 UTC, bugquestcontri
Details
Result of my tests, WFM with 4.0 (27.91 KB, application/vnd.oasis.opendocument.presentation)
2012-11-28 05:24 UTC, Rainer Bielefeld Retired
Details
Simple Sample (21.09 KB, application/vnd.oasis.opendocument.presentation)
2012-11-29 07:09 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bugquestcontri 2012-11-05 11:16:29 UTC
Created attachment 69555 [details]
Screenshot of Calc chart pasted as GDIMetafile in NormalView

Problem description: 
1. Created charts in Calc
2. Copied charts in Calc and pasted in Impress 1) as Star Object and 2) as GDI Metafile
3. Switch from Normal View to Slide View
Result:
Star Object chart lost column formating and show default format for columns
GDI Meta File chart shows correct formatting of columns but position of y-axis text is below center position

Steps to reproduce:
1.Create chart in Calc
2. Copy chart in Calc and paste in Impress 1) as Star Object and 2) as GDI Metafile
3. Switch from Normal View to Slide View and look at result

Current behavior:
Chart pasted as Star Object changes customized column format to default column format
Chart pasted as Meta File keeps customized column format but position of y-axis text is lower in Slide View than in Nomal View
t
Expected behavior:

Indendent of paste format customized column format and position of y-axis text should be the same in Normal and Slide Show View


Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 5.1; rv:16.0) Gecko/20100101 Firefox/16.0
Comment 1 bugquestcontri 2012-11-05 11:17:25 UTC
Created attachment 69556 [details]
Screenshot of Calc chart pasted as GDIMetafile in Slide Show View
Comment 2 bugquestcontri 2012-11-05 11:18:21 UTC
Created attachment 69557 [details]
Screenshot of Calc chart pasted as Star Object  in NormalView
Comment 3 bugquestcontri 2012-11-05 11:19:20 UTC
Created attachment 69558 [details]
Screenshot of Calc chart pasted as Star object  in Slide Show View
Comment 4 bugquestcontri 2012-11-20 13:43:21 UTC
please see also: https://bugs.freedesktop.org/show_bug.cgi?id=56763
I can be contacted
Comment 5 Petr Mladek 2012-11-26 12:19:15 UTC
The difference between normal and slide view is usually caused by the hardware acceleration. It might help to disable the checkbox "Tools/Options/View/Use Hardware Acceleration".

Could you please attach sample document that shows the problem? It could help a lot with fixing.

I can't confirm this easily without the test documents but I guess that this is an older bug. I guess that the disabled acceleration would help => it should not block the next bugfix release with other useful fixes => reducing the severity a bit.
Comment 6 bugquestcontri 2012-11-26 14:06:30 UTC
Created attachment 70590 [details]
Impress sample

there are 2 slides included. One should have a Star Object and the other a GDI metafile. However I cannot say which slides contains which file type.
Comment 7 Rainer Bielefeld Retired 2012-11-26 18:03:51 UTC
I see a very obvious gradient problem and nothing else

@bugquestcontri:
Thank you for your report – unfortunately important information is missing.
May be hints on <http://wiki.documentfoundation.org/BugReport> will help you to find out what information will be useful to reproduce your problem?
Please:
- Write a meaningful Summary describing exactly what the problem is
  Not "looks different", but 
- Attach a sample document (not only screenshot) or refer to an existing 
  sample document in an other Bug with a link; to attach a file to this 
  bug report, just click on "Add an attachment" right on this page.
- Attach screenshots with comments if you believe that that might explain the 
  problem better than a text comment. Best way is to insert your screenshots
  into a DRAW document and to add comments that explain what you want to show
  (attachment 68877 [details], attachment 68490 [details])
- Contribute a document related step by step instruction containing every 
  key press and every mouse click how to reproduce your problem 
  (similar to example in Bug 43431)
– if possible contribute an instruction how to create a sample document 
  from the scratch
- add information 
  -- what EXACTLY is unexpected
  -- and WHY do you believe it's unexpected (cite Help or Documentation!)
  -- concerning your PC (video card, ...)
  -- concerning your OS (Version, Distribution, Language)
  -- concerning your LibO version (with Build ID if it's not a public release)
     and localization (UI language, Locale setting)
  –- Libo settings that might be related to your problems 
    (video hardware acceleration, Experimental features enabled, ...)
  -- how you launch LibO and how you opened the sample document
  –- Whether your problem persists when you renamed your user profile 
     before you launch LibO (please see
     <https://wiki.documentfoundation.org/UserProfile#User_profile_location>)
  -- everything else crossing your mind after you read linked texts
Comment 8 bugquestcontri 2012-11-27 01:03:55 UTC
I will try to improve as much as possible.

As I am not an expert, it is difficult to know when information like
- PC (video card, ...)
- OS (Distribution, Language) 
- LibO localization (UI language, Locale setting)
- Libo settings that might be related to your problems 
    (video hardware acceleration, Experimental features enabled, ...)
- how you launch LibO and how you opened the sample document
- Whether your problem persists when you renamed your user profile 
   before you launch LibO
is important. therefore I typically add that I can be contacted.

Video card - where do I find this information?
In which cases you need all above information?
Does it help you if I provide you above information in this case?
Comment 9 Rainer Bielefeld Retired 2012-11-27 05:34:39 UTC
@bugquestcontri:
May be we should start with the most easy question: What EXACTLY is your problem? May be most of my questions become superfluous. My general hint is: always be precise. Do not write things like 
- "is bigger" 
- "looks different"
- "at the wrong place", 
but:
- "I metered in a screenshot and found the pasted object 1.25 times higher
   than the source object"
- "instead of expected gradient transparency I see constant transparency 
  (looks like 25%)
- "I have been used to see a capital "H" with exactly character hight below 
   x-axes", but since Version xx.x the distance increased to more or less a
   "Hg" (with additional ascender)
 
Some times it is difficult to find the roots of a problem, and then sometimes such additional information shows up a possible relation to an other bug, what leads to new 

And you are right, there should be some explication, I will add it at <http://wiki.documentfoundation.org/QA-FAQ> during the rest of the week.
Comment 10 bugquestcontri 2012-11-27 07:33:02 UTC
Created attachment 70643 [details]
another Impress file with sample slides and explanations
Comment 11 Rainer Bielefeld Retired 2012-11-27 08:05:03 UTC
Comment on attachment 70643 [details]
another Impress file with sample slides and explanations

Please use radio button "Auto Detect" when your create attachments!
Comment 12 bugquestcontri 2012-11-27 08:08:06 UTC
In order to increase the chance to detect the cause of the bug, I created a new sample (Example 2):
- I used the default template of LibO for Impress
- Copied the charts in Calc and pasted them into Impress with Paste Special 1- as Star Object, 2 - as GDI meta files. In the title of each slide you find the paste format information .

The Star Object format always (=whenever I used and went into slide show) changed from gradient filling of the columns to the full color filling of the columns. The GDI format also showed correct.

In general (and this lead to my bug report at the beginning)
The GDI metafile showed for a long time the gradient fillings also in slide show - so I though that this is the right format to be used. However suddenly also the GDI metafile slides changed from gradient filling to full color filling. Thus, non of the formats could be used to prepare a presentation because there was always the threat that the slide shows up with the wrong column fillings during a presentation..

When I did a lot of testing I additionally I observed that title of the y-axis moved down from the center position until the height of the x-axis (see Screenshot of Calc chart pasted as GDIMetafile in Slide Show View ) Strange so that in this occasion the column filling was displayed in the slide show with the gradient.

In the attachment "Impress Sample" you have slides, which changed the column fillings at the time of my testing (see bug report date). I saved the presentation under the name "Impress Sample" and deleted all other slides.

OS is XP / SP3
Comment 13 bugquestcontri 2012-11-27 08:09:12 UTC
"Please use radio button "Auto Detect" when your create attachments!" where is this button please?
Comment 14 Rainer Bielefeld Retired 2012-11-27 08:23:06 UTC
Created attachment 70644 [details]
Test kit with source document

Not reproducible with attached test kit and "LibreOffice 3.5.7.2 rc German UI/Locale [Build-ID: 3215f89-f603614-ab984f2-7348103-1225a5b] on German WIN7 Home Premium (64bit).

@bugquestcontri:
What is the difference in this bug to "Bug 57238 - Gradients in CHART elements not shown during SLIDESHOW"?
We need your source spreadsheet document with chart
Comment 15 Petr Mladek 2012-11-27 10:49:12 UTC
*** Bug 57238 has been marked as a duplicate of this bug. ***
Comment 16 Petr Mladek 2012-11-27 10:52:05 UTC
(In reply to comment #13)
> "Please use radio button "Auto Detect" when your create attachments!" where
> is this button please?

The radio button is on the "Add an Attachment" page. The problem is that the attached documents get wrong MIME, see the bug #55270.
Comment 17 Petr Mladek 2012-11-27 10:59:54 UTC
I see the problem with the document from the comment #10. The first slide has gradient in edit mode and full color during the slide show.

It might be enough to fix. Well, it would be great if you attach also the Calc file, so we could play with the cut&paste operation as well. The Rainer's example does not work, so there must be something special in your document.

Muthu, Radek, Thorsten, please have a look. See also https://bugs.freedesktop.org/show_bug.cgi?id=57238#c1. It seems to be an older bug.
Comment 18 bugquestcontri 2012-11-28 00:44:52 UTC
Created attachment 70711 [details]
Orignal Calc file with original charts

As requested the original file. See also information inside the file.
Comment 19 bugquestcontri 2012-11-28 01:07:09 UTC
"What is the difference in this bug to "Bug 57238 - Gradients in CHART elements not shown during SLIDESHOW"?"

Unfortunately I cannot see my original bug report text anymore. However, I am rather sure that the charts in Bug 57238 were created directly in Impress. "directly in Impress" means that I entered data in the data field of the chart in Impress.

As I saw the bug I then changed to create charts in Calc and worked with Copy & Paste Special as a work around. Normally I prefer to work directly in Impress (before in PowerPoint)

I checked  and found the slide of Bug 57238 and will make a separate attachment.
Comment 20 bugquestcontri 2012-11-28 01:36:32 UTC
Created attachment 70713 [details]
slide where I observed difference between normal view and slide show for the first time

the chart in the attached slide was created directly in Impress, meaning entering data in the data field of an Impress chart.
Comment 21 Rainer Bielefeld Retired 2012-11-28 05:24:31 UTC
Created attachment 70717 [details]
Result of my tests, WFM with 4.0

I checked the sample document 2012-11-28 00:44 UTC, bugquestcontri@online.de, LibreOffice 3.5.7.2 rc German UI/Locale [Build-ID: 3215f89-f603614-ab984f2-7348103-1225a5b] on German WIN7 Home Premium (64bit). 
Short summary: I can reproduce the problem in SLIDESHOW. Worksforme with 4.0

The sample contains several charts, to reproduce my results with 3.5.7.2:
1. download "OriginalFileForCharts.ods"
2. Open the docum ent by double click in WIN File Explorer
3. At rows 25 and following you see the left chart "Process Time View"
   Double click to get edit mode
4. Click most bottom yellow data in left bar "Data Point 1, Data series 1
   > 2 control points appear
5. 'Right click left control point -> Format Data Series -> Area.
   > You see that the area is filled with a gradient, but it seems that it is 
     filled with a gradient what does not exist? But is that the root of the
     problem?
6. Click into an empty cell or the sheet
7. Copy / Paste the chart to a new empty presentation and start 
    slide show, you will see the reported problem

To avoid problems with EXCEL import I finished the test and started a new one with a simple ODS:

10. Download My Test kit with source document 2012-11-27 08:23 UTC
11. Unzip test kit
12. Launch LibO, open source.ods
13. double click chart to get edit mode
14. click bottom blue data in left vertical bar
   > control points appear
15. 'Right click left control point -> Format Data Series -> Area -> Fill
16. Replace color "blue" by "Gradient", first you see, In Tab 'Transparence'
    click 'none'
17. Replace other colors as per step 16 by next gradients
18. copy / paste the Chart to a new Presentation
19. Start Slide show
    Bug: Instead of 4 colorful gradients in the data bars you only see
         flat brown and yellow data areas
20. You can copy / Paste the chart in the spreadsheet and in area 
    'Transparency' you select "Gradient" for all Data series
21. When copy / paste this second chart to a presentation everything will
    work more or less as expected in Slide Show

31. Save / close presentation
32. Reopen  with LibO 3.6.4.1
    > Same bad result as in 3.5.7.2
33. Save / close presentation
34. Reopen with parallel installation of  "LOdev  4.0.0.0.alpha0+   -  
    ENGLISH UI / German Locale  [Build ID: a2b3ee)]"  {2012-11-23} 
    on German WIN7 Home Premium (64bit) with separate /4 User Profile for 4.0
    Everything works fine

You can test with attachment 70711 [details]: Original Calc file with original charts 
and you will see that everything will work fine LibO 4.0
Attachment 70643 [details]: another Impress file with sample slides and explanations also works fine with LibO 4.0

But the problem with attachment 70590 [details]: Impress sample

I obsoleted attachment 70590 [details] and all other attachment what are not related to the problem what is solved with LibO 4.0. I will submit a new bug for those problems, soon (If I can't find an existing bug for that)
Comment 22 Rainer Bielefeld Retired 2012-11-28 05:36:23 UTC
Already [Reproducible] with "LibreOffice Portable 3.3.0  - WIN7  Home Premium (64bit) German UI [OOO330m19 (Build:6) tag libreoffice-3.3.0.4]" 

@all
Please do comments here only concerning the WFM 4.0 bug, the history here is complicated enough.

@Thorsten, Radek:
Can you find the commit repairing that bug and is it possible to backport the fix to 3.6?
Comment 23 Rainer Bielefeld Retired 2012-11-29 06:59:42 UTC
My conclusion were incorrect, has nothing to do with "copied from Calc"
Comment 24 Rainer Bielefeld Retired 2012-11-29 07:09:35 UTC
Created attachment 70772 [details]
Simple Sample

"SimpleChartInPresentation.odp" contains the most simple chart created directly in presentation document with changed formatting for data series; it shows the problem:
Column 1 Formatting is gradient color, works fine
Column 2 formatting is gradient picture without transparency, does not work
in slide show
Column 3 formatting is the same gradient picture as for coulumn 2, but with transparency 1%. This works fine in slide show
Comment 25 bugquestcontri 2012-11-29 08:29:22 UTC
Pretty well done!!!! Now I curios how long it takes to get this bug out. I hope soon.
Comment 26 bugquestcontri 2012-11-29 10:38:43 UTC
I "played" a bit around with the information Rainer reported and made a new bug report 

https://www.libreoffice.org/bugzilla/show_bug.cgi?id=57681

Forgive me guys, I reported it to help!
Comment 27 ign_christian 2013-06-13 04:36:28 UTC
It seems correct on LO 4.0.4.1 (Win7 32bit)

Please REOPENED if that still persists on latest stable release
Comment 28 bugquestcontri 2013-06-14 14:08:37 UTC
Thanks for this good news and all the work done. Once I am using 4.0.4 I will go back to my personal column chart lay out and make a test. 
A nice weekend to everybody who was involved.