Bug 56794 - Using Numbering and copy text and numbering is copied despite not being marked for copying
Summary: Using Numbering and copy text and numbering is copied despite not being marke...
Status: RESOLVED DUPLICATE of bug 49076
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.3.2 release
Hardware: x86 (IA32) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-06 08:21 UTC by grofaty
Modified: 2013-04-14 08:31 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
Numbering copied despite not beeing selected (35.71 KB, image/png)
2012-11-06 08:21 UTC, grofaty
Details

Note You need to log in before you can comment on or make changes to this bug.
Description grofaty 2012-11-06 08:21:37 UTC
Created attachment 69595 [details]
Numbering copied despite not beeing selected

1. In LibreOffice Writer open new document.
2. Click on button Numbering On/Off. Note: Number "1." appears in first line.
3. In first line type in: This is test line number one.
4. Press ENTER.
5. Number "2." is displayed in second line. In second line type in: This is test line number two.
6. With mouse select "number two." and copy the text.
7. Paste the text to text editor e.g. Notepad.
And pasted text is: 2. number two.
You notice there is "2." pasted despite I didn't mark it for coping. I expect to be copied only the text I actually marked so "number two."

P.S. See attached print-screen (png file).
Comment 1 grofaty 2012-11-06 08:36:55 UTC
Just a note in step 2 if "Bullets On/Off" from toolbar is selected instead of "Numbering On/Off" then this problem does not appear. So it looks like a problem only with "Numbering On/Off".
Comment 2 grofaty 2012-12-21 16:14:06 UTC
I retested the problem in LibreOffice 3.6.4.3 and problem still persists. Very annoying bug.
Comment 3 grofaty 2013-02-27 12:38:25 UTC
Retested in LibreOffice 3.6.5.2 on Windows XP and problem still persists.
Comment 4 Brenda Granados 2013-03-01 19:03:47 UTC
Hi. I tested this on Ubuntu Linux and Windows 8, using LibreOffice 4.0.0.3. I used gedit on Ubuntu, and Notepad and Notepad++ on Windows. I confirmed that even when you are copying just a single word on a numbered line, the number will be copied. One can also copy and paste text from line 1, line 2, and line 1 again, and obtain this:

1. line text number one
2. line text number two
1. line text number one

After some investigation, this bug is common with a lot of word processors when auto-numbering is on. The only way around it is to turn off the auto-numbering, copy/paste, and then turn it back on. I'm really not sure if this is fixable, in my opinion. It might even be intentional. I don't know. I will mark this as new.
Comment 5 Owen Genat (retired) 2013-04-14 08:31:14 UTC
Even though the architecture of this bug is x86 (IA32) it would appear to be a duplicate of FDO#49076 (currently marked as architecture x86-64).

*** This bug has been marked as a duplicate of bug 49076 ***