Download it now!
Bug 56797 - EDITING: Wrong behavior of text selection (via mouse) between 2 pages
Summary: EDITING: Wrong behavior of text selection (via mouse) between 2 pages
Status: RESOLVED DUPLICATE of bug 49994
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.3.2 release
Hardware: x86-64 (AMD64) All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-06 09:21 UTC by Frantisek Erben
Modified: 2013-03-07 15:18 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
ScreenRecord (1.21 MB, video/mp4)
2012-11-06 09:21 UTC, Frantisek Erben
Details
Test .odt file (32.61 KB, application/vnd.oasis.opendocument.text)
2012-11-06 09:22 UTC, Frantisek Erben
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frantisek Erben 2012-11-06 09:21:55 UTC
Created attachment 69598 [details]
ScreenRecord

How to reproduce:
Load included .odt, go to page 6 try to select text with mouse (click and move):„PDF was not resized properly when used for web marketing, so that, when viewed on an iPhone, the logo looked like one of the firm's planes had landed on it.“.
It doesn't matter if you select text from top of text to bottom or vrom bottom to top.

What happens:
As you can see on the ScreenRecord, at least every 2nd attempt ends with bad selection (jump to begin of document unexpectedly) :-(

What should happens:
Standard text selection.

Workaround:
Select only via tripleclick (whole paragraph) or via Shift+arrows - realy annoying user unfiendly

Additional information:
It occure and I reproduced it on Mac OS X and Windows 7, so there is high probability that it occure on all platforms.
Comment 1 Frantisek Erben 2012-11-06 09:22:55 UTC
Created attachment 69599 [details]
Test .odt file
Comment 2 Brenda Granados 2013-03-07 15:13:53 UTC
Aha! I can confirm that this behavior occurs. In addition, it is a duplicate of another bug that has already been confirmed. It is because it is a table of 2 cells that span multiple pages, and the table headings repeat. If you create a table where headings do not repeat, and the cells expand over multiple pages, you will not experience the same issue of "jumping".

*** This bug has been marked as a duplicate of bug 49994 ***