Bug 56798 - FILEOPEN: Wrong number of levels shown in TOC when opening some MS Word files
Summary: FILEOPEN: Wrong number of levels shown in TOC when opening some MS Word files
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-06 09:31 UTC by Michael Kleidt
Modified: 2014-10-22 08:11 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Word document with TOC (35.50 KB, application/msword)
2012-11-06 09:31 UTC, Michael Kleidt
Details
MS Word screenshot (18.52 KB, image/gif)
2012-11-06 09:32 UTC, Michael Kleidt
Details
LO screenshot (30.19 KB, image/gif)
2012-11-06 09:33 UTC, Michael Kleidt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Kleidt 2012-11-06 09:31:40 UTC
Created attachment 69600 [details]
Word document with TOC

I open a word document with LibreOffice and found, that the TOC was only shown to level 2 instaed of level 3.

I could not reproduce this problem with a blank document adding a "fresh" TOC. So I copy the TOC to the blank document and add some headings (see attached TOC.doc). I create the document with Word 2003 SP3.

If you load the document with MS Word, you will get a TOC with 3 levels (up to heading 3) and the properties of the TOC shows "3" for number of levels (see attached "MS Word.gif" screenshot)

If you load the document with LO 3.6, you will get a TOC with 2 levels (up to heading 2) and the properties of the TOC shows "2" for number of levels (see attached "LO 3.6.gif" screenshot)
Comment 1 Michael Kleidt 2012-11-06 09:32:26 UTC
Created attachment 69601 [details]
MS Word screenshot
Comment 2 Michael Kleidt 2012-11-06 09:33:04 UTC
Created attachment 69602 [details]
LO screenshot
Comment 3 Florian Reisinger 2013-04-21 10:41:27 UTC
Confirmed with Version 4.0.3.1 (Build ID: a67943cd4d125208f4ea7fa29439551825cfb39) @Win 7 x64
Comment 4 Buovjaga 2014-10-20 11:57:12 UTC
Can't repro on Win 7 64-bit 4.3.2.2 or dev build Version: 4.4.0.0.alpha0+
Build ID: 3e2bd1e4022e25b77bcc8eba5e02c1adc57008a1
TinderBox: Win-x86@42, Branch:master, Time: 2014-10-16_01:04:13
Comment 5 Michael Kleidt 2014-10-21 09:19:00 UTC
I just tested it in Version: 4.3.0.4 and it is fixed!