Bug 56811 - CONFIGURATION: Duplicate Shortcut description
Summary: CONFIGURATION: Duplicate Shortcut description
Status: RESOLVED DUPLICATE of bug 108458
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Customize-Dialog
  Show dependency treegraph
 
Reported: 2012-11-06 17:25 UTC by qqqqqqqqq9
Modified: 2017-12-19 12:20 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description qqqqqqqqq9 2012-11-06 17:25:29 UTC
Problem description: 

Steps to reproduce:
1. Click Tools-Customise
2. Choose the Insert-Category and scroll-down to formula

Current behavior:
There are to entries "formula"
one edits formula in table cells the other inserts a math formular.

Expected behavior:
They entries should be descriptive, e.g. "math formula" and "table formula". Furthermore, the "table formula" should be placed in the table category for sake of consistency with the menu ordering.


Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (X11; Linux i686) AppleWebKit/534.34 (KHTML, like Gecko) konqueror/4.9.2 Safari/534.34
Comment 1 tommy27 2012-12-28 21:37:54 UTC
confirmed. still here in LibO 4.0 beta2. Windows Vista 64bit

> Expected behavior:
> They entries should be descriptive, e.g. "math formula" and "table formula".
> Furthermore, the "table formula" should be placed in the table category for
> sake of consistency with the menu ordering.
> 

totally agree with you.

I see other duplicates in the Writer customize keyboard panel (I have not checked if they have different actions):

Application/Open
Edit/Backspace
Edit/Fields
Insert/Comment
Format/Center
Format/Justified
Format/Left
Format/Right
Format/Top
Table/Sort
Numbering On/Off

and a triplicate:

Format/Centered

probably other duplicates exist in Calc and Impress customize keyboard panel as well.
Comment 2 tommy27 2014-01-11 16:47:43 UTC
the issue is inherited from OOo since those duplicated strings are already present there.

as reported by user a better description for those identical entries (which instead have different functions) is needed...

it's indeed frustrating to identify which is the exact function you wanna map on your keyboard.

I think all the strings of that menu should be reviewed and finally fixed.
this will need some work for the localization teams but I thinks it's worth it.
Comment 3 Joel Madero 2015-05-02 15:41:39 UTC Comment hidden (obsolete)
Comment 4 tommy27 2015-05-03 08:15:31 UTC
tested under LibO 5.0.0.0.alpha1+ (x64)
Build ID: 967b8c33225ae2aab5733639f0713a84cb1971da
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-04-25_04:11:40
Locale: it_IT

most of those duplicate entries are still there.

@Adolfo
is this something you can take a look at?
Comment 5 QA Administrators 2016-09-20 09:37:30 UTC Comment hidden (obsolete)
Comment 6 Maxim Monastirsky 2017-12-19 12:20:01 UTC
This bug is earlier, but Bug 108458 has a long discussion about how to improve things, so closing this one as a duplicate.

*** This bug has been marked as a duplicate of bug 108458 ***