Download it now!
Bug 56823 - Saving in MS Office formats loses data range
Summary: Saving in MS Office formats loses data range
Status: RESOLVED DUPLICATE of bug 41425
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-06 21:22 UTC by Leo
Modified: 2014-06-24 06:10 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Sample document that show the bug (7.78 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-11-08 23:54 UTC, billhook
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Leo 2012-11-06 21:22:10 UTC
I created a data range and created a validation field (drop down) with that range.

This all works in in the standard open format (.ods), but looses the data range when I save the spreadsheet in MS formats (xls, xlsx).
Comment 1 billhook 2012-11-08 23:54:24 UTC
Created attachment 69782 [details]
Sample document that show the bug
Comment 2 billhook 2012-11-09 00:09:43 UTC
Confirmed on LO 3.6.3.1 Windows Vista 32bit

To reproduce:

1. Open the attached .ods. There is a range called "TheRange".
2. Save as .xls
3. Close and reopen the .xls
4. Go Data->Select Range

There should be a range called "TheRange"

There isn't.
Comment 3 billhook 2012-11-09 00:10:41 UTC
This may be related to 

Bug 42910 - [Calc] xls export corrupts some formulas with named ranges
Comment 4 ace_dent 2014-01-22 13:43:49 UTC
This is still a problem, tested in Version: 4.2.0.2
Build ID: 125e3e788aa207ab80b6f39e74ef57af7e2129b6 MacOS.

Named ranges don't survive roundtrip ODS>XLS>ODS. Tested with very simple case.
Comment 5 ign_christian 2014-06-24 06:10:59 UTC

*** This bug has been marked as a duplicate of bug 41425 ***