Bug 56829 - EDITING: ARRAY, simple array change data one row up, if second row cell is number.
Summary: EDITING: ARRAY, simple array change data one row up, if second row cell is nu...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: Other Windows (All)
: high blocker
Assignee: Kohei Yoshida
URL:
Whiteboard: target:3.7.0
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-11-07 01:27 UTC by m.a.riosv
Modified: 2013-11-13 20:37 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Simple array test (10.00 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-11-07 01:27 UTC, m.a.riosv
Details

Note You need to log in before you can comment on or make changes to this bug.
Description m.a.riosv 2012-11-07 01:27:39 UTC
Created attachment 69650 [details]
Simple array test

Win 7x64 Ultimate.
master~2012-11-03_01.04.28_LibO-Dev_3.7.0.0.alpha0_Win_x86_install-arc_en-US.tar
master~2012-11-03_09.27.58_LibO-Dev_3.7.0.0.alpha0_Win_x86_install_en-US (MinGW)

Steps:
1) new spreadsheet.
2) introduce from A1 a simple data like:

titulo1	titulo	titulo3	titulo4	titulo5	titulo6	titulo7
hola	1	3	vay	2	3	vay
adios	2	4	ven	3	4	ven

3) in any cell out of this range introduce as array formula:

=A1:G3

4) result in:

titulo1	1	3	titulo4	2	3	titulo7
hola	2	4	vay	3	4	vay
adios			ven			ven

5) where there is an number in the second cell of the column, is moved a row up in the resulting array.
Comment 1 Kohei Yoshida 2012-11-08 21:45:34 UTC
Confirmed.  I'll take a look.
Comment 2 Kohei Yoshida 2012-11-09 00:53:49 UTC
Fixed.
Comment 3 Kohei Yoshida 2012-11-09 00:54:14 UTC
Thanks for testing the master build. We appreciate it. :-)
Comment 4 Not Assigned 2012-11-09 00:57:23 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=78bf3c9abd4a8cd939e7ba4399ae4aab9f3b2982

fdo#56829: Correctly pass element values to matrix.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 m.a.riosv 2012-11-09 21:21:53 UTC
Hi Kohei, thanks for the quick fix.

Seems to be solved in MinGW
master~2012-11-09_09.54.22_LibO-Dev_3.7.0.0.alpha0_Win_x86_install-arc_en-US.tar

Out of curiosity, why it only happened with numbers in cells?
Comment 6 Kohei Yoshida 2012-11-09 22:38:28 UTC
(In reply to comment #5)

> Out of curiosity, why it only happened with numbers in cells?

It only happened when the range had a mix of texts and numbers.  The code that processed the input was simply doing the wrong thing.
Comment 7 m.a.riosv 2012-11-09 23:42:47 UTC
Hi Kohei, thanks.