Bug 56896 - CONDITIONAL FORMATTING, having the option to be always in action regardless of the state of autocalculate.
Summary: CONDITIONAL FORMATTING, having the option to be always in action regardless o...
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-09 00:02 UTC by m.a.riosv
Modified: 2012-11-18 00:28 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Sample intensive use of conditional formatting (334.57 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-11-09 02:41 UTC, m.a.riosv
Details

Note You need to log in before you can comment on or make changes to this bug.
Description m.a.riosv 2012-11-09 00:02:09 UTC
With conditional formatting in large ranges, and heavy calculations, becomes really unusable, with an intensive use of the processor.

Allow conditional formatting works without autocalculate enable, would be very useful, specially with heavy spreadsheets or slow computers.
Comment 1 Markus Mohrhard 2012-11-09 00:42:30 UTC
Normally conditional formatting should be independent from autocalculation. Everything else is a bug and would need a test document showing the issue.

Data Bars and Color scale are except for the formula case surely independent from autocalculation so the only remaining problem might be our use of ScFormulaCell::Interpret in the conditional format code. But we can surely fix this problem in some way.

Can you please also open a bug report for the slow conditional formats with a test document. I would like to see such a problem to be able to fix the underlying issues.
Comment 2 m.a.riosv 2012-11-09 02:41:41 UTC
Created attachment 69784 [details]
Sample intensive use of conditional formatting

Attached a file sample.

Changing the value in column A from 1 to 6, must change the format of cells in the row, but this not happen without autocalculate enabled, (F9 or Ctrl+Shif+F9).

Also is very slow saving the file after change any value with autocalculate enable. I have observed that sometimes save file is quick minimizing the window.

I don't know, only my speculation, but it seems an intensive screen refresh.
Comment 3 Markus Mohrhard 2012-11-14 11:19:42 UTC
Seems this is not the reason for the performance regression. The performance problem seems to be related to the pure formula handling and has nothing to do with the cond format code.

While the conditional format code might benefit from some performance improvements it seem to count for less than 1% of the time spend updating the document.

Now I have no longer a clue what might be the problem here. Have to spend more time trying to find a pattern in these calls.
Comment 4 m.a.riosv 2012-11-14 13:12:11 UTC
Please Markus, can you take a look to this bug:

https://bugs.freedesktop.org/show_bug.cgi?id=57028

there is a file sample, where is very perceptible the difference, in my computer, calculate time is reduced from more than two minute to a second, to enter o delete a cell, when conditional format is deleted.


On other hand, what about CF working with recalc or hard recalc?

Thanks