Bug 56905 - Moz-free Outlook Express Address Book driver
Summary: Moz-free Outlook Express Address Book driver
Status: RESOLVED DUPLICATE of bug 56902
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Windows (All)
: medium enhancement
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: ToBeReviewed
Keywords: difficultyInteresting, easyHack, skillCpp, skillSql
Depends on:
Blocks: MozBaseKillOff
  Show dependency treegraph
 
Reported: 2012-11-09 06:16 UTC by Lionel Elie Mamane
Modified: 2017-02-14 08:58 UTC (History)
13 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lionel Elie Mamane 2012-11-09 06:16:25 UTC
Make a LibreOffice connectivity/sdbc driver that does not use the in-tree ancient Mozilla copy.

http://forums.devx.com/archive/index.php/t-66624.html
says one can do that through the Windows Address Book (WAB) API. It
seems to be deprecated (see
http://msdn.microsoft.com/en-us/library/ms629361%28v=VS.85%29.aspx
). The replacement is Windows Contacts API
http://msdn.microsoft.com/en-us/library/ms735779%28v=vs.85%29.aspx
that's a venue to explore, too.

We need to pay attention that Windows Contacts API is available on as old Windows as we want to support.


This needs handling the SQL ourselves, like our mork driver does (connectivity/source/drivers/mork)
Comment 1 Joel Madero 2014-02-27 23:20:43 UTC
In order to limit the confusion between ProposedEasyHack and EasyHack and to make queries much easier we are changing ProposedEasyHack to NeedsDevEval.

Thank you and apologies for the noise
Comment 2 Michael Meeks 2014-07-26 22:56:45 UTC
A great easy-hack, though not entirely trivial for sure :-)
Comment 3 Alex Thurgood 2015-01-03 17:39:24 UTC
Adding self to CC if not already on
Comment 4 Robinson Tryon (qubit) 2015-12-13 13:24:11 UTC
Migrating Whiteboard tags to Keywords: (easyHack, difficultyInteresting, skillCpp, skillSql)
[NinjaEdit]
Comment 5 Robinson Tryon (qubit) 2016-02-18 14:52:22 UTC
JanI is default CC for Easy Hacks (Add Jan; remove LibreOffice Dev List from CC)
[NinjaEdit]
Comment 6 jani 2016-04-21 06:07:23 UTC
All information seems to have moved to 56902.

*** This bug has been marked as a duplicate of bug 56902 ***
Comment 7 Stephan Bergmann 2016-04-21 07:14:12 UTC
(In reply to jan iversen from comment #6)
> All information seems to have moved to 56902.
> 
> *** This bug has been marked as a duplicate of bug 56902 ***

But now, the information is kind of lost at the tracking bug 56902 that one of the three things which that bug blocks on is implementing a "Moz-free Outlook Express Address Book driver".