Bug Hunting Session
Bug 56942 - [Donation] Custom currency setting also affects donation selector
Summary: [Donation] Custom currency setting also affects donation selector
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: WWW (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-10 00:39 UTC by Naruhiko Ogasawara
Modified: 2015-04-19 14:00 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Naruhiko Ogasawara 2012-11-10 00:39:04 UTC
How to reproduce:

1. Open the donation page (e.g. http://donate.libreoffice.org/)
2. Select "Or enter a custom amount and currency
   (only those marked with * are also available via PayPal)"
3. Choose currency "JPY" (Japanese Yen).
4. Re-select "Select one of the default values" and choose one of the value
   (e.g. 50 USD).
5. Click "Donate via Credit Card".


Excepted Result:

- Move to donation process page with "50 USD."

Current Result:

- Move to donation process page, but with "50 JPY."


NOTE: http://donate.libreoffice.org/ja have same problem.
Comment 1 Marc Pare 2012-11-10 07:28:49 UTC
I can confirm this.

I looks like the fix is to remove the "USD" from the default values. The "USD" could perhaps be replace by a generic symbol or word, or, just leave it out altogether?
Comment 2 Florian Effenberger 2012-11-10 07:49:08 UTC
Cc'ing Christian
Comment 3 Thomas Hackert 2013-07-04 17:43:22 UTC
Hello Ogasawara-san, *,
thank you for reporting your bug :)
I can confirm it with Firefox 24.0a2 (2013-07-04) under Debian Testing AMD64, if this is relevant ... ;)
Sorry for the inconvenience
Thomas.
Comment 4 QA Administrators 2015-04-01 14:39:56 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-01
Comment 5 Buovjaga 2015-04-19 13:42:35 UTC
Reproduced still.
Comment 6 Florian Effenberger 2015-04-19 13:55:24 UTC
Short description probably is: "Custom currency selector takes precedence" or somesuch

Can you refile in Redmine in the infrastructure project?

Thanks!
Comment 7 Buovjaga 2015-04-19 14:00:11 UTC
(In reply to Florian Effenberger from comment #6)
> Short description probably is: "Custom currency selector takes precedence"
> or somesuch
> 
> Can you refile in Redmine in the infrastructure project?
> 
> Thanks!

Done: https://redmine.documentfoundation.org/issues/1229

Closing as NOTOURBUG.