Bug 57008 - EDITING: Selection: Wierd behavior using Shift+Up Arrow after Ctrl-C - Ctr-V
Summary: EDITING: Selection: Wierd behavior using Shift+Up Arrow after Ctrl-C - Ctr-V
Status: RESOLVED DUPLICATE of bug 62436
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.1.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-12 10:23 UTC by joel.tuberosa
Modified: 2014-02-26 00:32 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description joel.tuberosa 2012-11-12 10:23:45 UTC
Problem description: 

Steps to reproduce:
1. Copy a cell with ctrl-c
2. Move 1 cell downer with the down-arrow key
3. Paste the copied cell with ctrl-v
4. Hold shift and press the up-arrow to select the current cell and the upper one.

Current behavior:
This selects all cells comprised betweed the last selection and A1. For example, if I do this on B2, this will select A1, A2, B1, B2.

Expected behavior:
I was expecting this manipulation to select only 2 cells. Like if you do this without the copy-paste steps (1-3).

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0
Comment 1 m.a.riosv 2012-11-13 00:01:32 UTC
Confirmed
Win 7x64 Ultimate
Version 3.6.3.2 (Build ID: 58f22d5)
Version 3.7.0.0.alpha0+ (Build ID: 52a7a8) MinGW
Comment 2 tmacalp 2014-02-26 00:32:15 UTC
Looks like this could be explained by the behavior I listed in bug 62436.  After a paste, the next selection range seems to be erroneously selected based on cell A1.

You can test this without even inserting anything:
1. Select any random cell (C10 in this case)
2. Copy
3. Paste
4. Shift-right

It will select a range from your current cell(C10) to a cell wrongly based on A1.  Shift-right in this case takes us to A2, so C10:A2 will be selected.

*** This bug has been marked as a duplicate of bug 62436 ***