Download it now!
Bug 57028 - EDITING: Extremely slow when i have change a cell in a calc sheet
Summary: EDITING: Extremely slow when i have change a cell in a calc sheet
Status: RESOLVED DUPLICATE of bug 57896
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.3.2 release
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: perf, regression
: 58835 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-11-12 19:17 UTC by VLB
Modified: 2015-12-15 11:05 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
File where the calculation is slow in 3.6.3.2 (1.69 MB, application/vnd.oasis.opendocument.spreadsheet)
2012-11-13 07:03 UTC, VLB
Details

Note You need to log in before you can comment on or make changes to this bug.
Description VLB 2012-11-12 19:17:12 UTC
Windows 7 64 bits LO 3.6.3.2 and LO 3.6.4.0+ (Build ID: 08ca08d)

I have a spreadsheet and when i have change a cel the calculation in LO is     +/- 1 min 10s.

When i use Excel the calculation is 1 sec!

The sheet isn't used for public.
Comment 1 VLB 2012-11-12 19:31:50 UTC
I have check on windows 7 64 bits LO 3.5.7

There is the calculation normal with 1 sec.
Comment 2 m.a.riosv 2012-11-12 23:57:08 UTC
Can you attach a sample file?

First please remember delete any confidential information, it will have public access.
Comment 3 VLB 2012-11-13 07:00:30 UTC
I attach a file and you do the next for see the issue:

Go to cel "EN 1993_1_1" D80 and delete the value, than the calculation is slow.

Or change the cel "EN 1993_1_1" B87 too value 2000 and is too slow.
Comment 4 VLB 2012-11-13 07:03:10 UTC
Created attachment 69980 [details]
File where the calculation is slow in 3.6.3.2
Comment 5 m.a.riosv 2012-11-13 12:00:36 UTC
Confirmed
Win 7x64 Ultimate
Version 3.6.3.2 (Build ID: 58f22d5)
Version 3.7.0.0.alpha0+ (Build ID: 52a7a8) MinGW

Removing all conditional formatting, seems to eliminate the problem.

I have not could find out if a specific condition is the source of the problem.

Maybe a problem similar to my bug report:
https://bugs.freedesktop.org/show_bug.cgi?id=49764
[EDITING] Conditional formatting make very slow introduce data in cells with conditional formatting. (RESOLVED FIXED)

But now, EN 1993_1_1.D80 has no conditional formatting.
Comment 6 m.a.riosv 2012-11-14 13:11:42 UTC
Win 7x64 Ultimate I3-4GB
LibreOffice Version 3.6.3.2 (Build ID: 58f22d5)

Steps:
- Opening attached file.
- Recalc | hard recalc: 2 seconds.
- Delete cell EN_1993_1_1.D80: 140 seconds.
- Recalc | hard recalc: 2 seconds.
- Enter -10 in cell EN_1993_1_1.D80: 135 seconds.
- Delete cell EN_1993_1_1.D80: 1 seconds.
- Recalc | hard recalc: 2 seconds.
- Enter -10 in cell EN_1993_1_1.D80: 135 seconds.
- Deleting all conditional format in EN_1193_1_1.
- Recalc | hard recalc: 2 seconds.
- Delete cell EN_1993_1_1.D80: 1 seconds.
- Recalc | hard recalc: 2 seconds.
- Enter -10 in cell EN_1993_1_1.D80: 1 seconds.

The issue is not there with LibreOffice 3.3.4.
Comment 7 VLB 2012-11-14 18:28:32 UTC
The issue is not there with LibreOffice 3.5.7.2


The issue is also there with LO master 4.0.0.0 alfa0.
Comment 8 VLB 2012-11-24 12:23:04 UTC
(In reply to comment #5)
> Confirmed
> Win 7x64 Ultimate
> Version 3.6.3.2 (Build ID: 58f22d5)
> Version 3.7.0.0.alpha0+ (Build ID: 52a7a8) MinGW
> 
> Removing all conditional formatting, seems to eliminate the problem.
> 
> I have not could find out if a specific condition is the source of the
> problem.
> 
> Maybe a problem similar to my bug report:
> https://bugs.freedesktop.org/show_bug.cgi?id=49764
> [EDITING] Conditional formatting make very slow introduce data in cells with
> conditional formatting. (RESOLVED FIXED)
> 
> But now, EN 1993_1_1.D80 has no conditional formatting.

In the sheet there is much conditional formatting in other cells.
Is this the problem and how it is solve the problem?
Comment 9 m.a.riosv 2012-11-24 21:32:20 UTC
"
Markus Mohrhard changed bug 57028
What 	        Removed 	Added
Keywords 	regression 	 

You are receiving this mail because:
You are on the CC list for the bug.
"

Please, could you explain why the key "regression" was deleted?.

As @vlb has indicated:
The issue is not there with LibreOffice 3.5.7.2
The issue is there with LibreOffice 3.6.3.2
The issue is there with LO master 3.7.0.0 alfa0.

And as I have verified:
The issue is there with LibreOffice 3.6.4.1
The issue is there with LO master 4.0.0.0 alfa1.
Comment 10 Markus Mohrhard 2012-11-24 23:11:06 UTC
Because it is a performance issue which we (the calc team) track with the pref keyword.

This makes it possible for us to keep track of different bugs.
Comment 11 VLB 2012-12-17 18:15:45 UTC
I can confirm this issue in LO Versie 4.0.0.0.beta1 (Bouw-id: 87906242e87d3ddb2ba9827818f2d1416d80cc7)on windows 7 64 bits.
Comment 12 Cor Nouws 2012-12-23 22:44:41 UTC
4.0 beta1 (sorry, not yet installed beta2) on Linux freezes..

@markus: When openend in 3.5.7, I see there are a lot of excel_condit_formatting# styles. Could be related ?

(Preformance issues are bad - so I take the freedom to promote to major..)
Comment 13 Markus Mohrhard 2012-12-26 19:11:00 UTC
http://cgit.freedesktop.org/libreoffice/core/commit/?id=7c528f40e0aea9386d175b007974c02d265f96c6 fixes the problem now.

*** This bug has been marked as a duplicate of bug 57896 ***
Comment 14 checkdizz 2013-01-05 16:44:11 UTC
I observed similar behavior after an upgrade from 3.5.7 to 3.6.4.3 (Dutch) and posted a bug report: https://bugs.freedesktop.org/show_bug.cgi?id=58835. It turns out this is another duplicate of this same bug. Version 4.0.0.0.beta2 had the same issue.

My question is if you can incorporate the above solution in version 3.6.4.4 or 3.6.5? It is quite an annoying bug and withholds me from upgrading. Thanks in advance.
Comment 15 VLB 2013-01-05 23:06:56 UTC
(In reply to comment #14)
> I observed similar behavior after an upgrade from 3.5.7 to 3.6.4.3 (Dutch)
> and posted a bug report: https://bugs.freedesktop.org/show_bug.cgi?id=58835.
> It turns out this is another duplicate of this same bug. Version
> 4.0.0.0.beta2 had the same issue.
See issue 57896 is solved later than versie 4.0 beta 2, i have check in the nightly builds http://dev-builds.libreoffice.org/daily/ and there it is solved the bug.


> My question is if you can incorporate the above solution in version 3.6.4.4
> or 3.6.5? It is quite an annoying bug and withholds me from upgrading.
> Thanks in advance.
I hope too that this issue solve for 3.6.5, do not upgrade to 3.6.4 it is bad!
Comment 16 m.a.riosv 2013-08-22 23:24:07 UTC
*** Bug 58835 has been marked as a duplicate of this bug. ***
Comment 17 Robinson Tryon (qubit) 2015-12-15 11:05:10 UTC
Migrating Whiteboard tags to Keywords: (perf)
[NinjaEdit]