Bug Hunting Session
Bug 57051 - LOdev 3.7.0.0.alpha0 daily build does not start at all, attempting to load libraries from /usr/local/lib/
Summary: LOdev 3.7.0.0.alpha0 daily build does not start at all, attempting to load li...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium critical
Assignee: Caolán McNamara
URL:
Whiteboard:
Keywords:
: 56991 (view as bug list)
Depends on:
Blocks: mab4.0
  Show dependency treegraph
 
Reported: 2012-11-13 07:16 UTC by Roman Eisele
Modified: 2012-11-14 15:07 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Mac OS X log file for LOdev 2012-11-12, which does not start (2.16 KB, text/plain)
2012-11-13 07:16 UTC, Roman Eisele
Details
Mac OS X log file for LOdev 2012-11-10, does not start (2.14 KB, text/plain)
2012-11-13 07:51 UTC, Roman Eisele
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Eisele 2012-11-13 07:16:27 UTC
Created attachment 69981 [details]
Mac OS X log file for LOdev 2012-11-12, which does not start

The newest LOdev 3.7.0.0.alpha0 daily build (pull time: 2012-11-12 06:49:30) for Mac OS X, from

http://dev-builds.libreoffice.org/daily/MacOSX-Intel@1-built_no-moz_on_10.6.8/master/2012-11-12_06.49.30/

does not work at all: if I try to start the LOdev application, Mac OS X just reports that it can not be opened. Resetting the LOdev user profile does not help. I attach the Mac OS X log file. The most important section reads:

“
Dyld Error Message:
  Library not loaded: /usr/local/lib/liblangtag.1.dylib
  Referenced from:    /Users/futurus/Applications/LOdev 2012-11-12/LOdev 
                      2012-11-12.app/Contents/MacOS/libi18nisolang1gcc3.dylib
  Reason: image not found
”

So LibreOffice attempts to load the system liblangtag.1.dylib, but it is not at the mentioned location. This is on Mac OS X 10.6.8. So I guess that the build machine has a liblangtag.1.dylib installed at the mentioned location, but my machine does not have it. Thsi means that liblangtag.1.dylib is not installed there by default, and that LibreOffice should *not* attempt to load liblangtag.1.dylib from that location ...

This reminds me heavily of Bug 54023 - “CRASH on launch when loading local libiconv.2.dylib”; maybe the reasons are similar, and therefore also the fix could be similar?

Please fix this soon; as long as this bug exists, I can not do any QA work with a current master build!
Comment 1 Roman Eisele 2012-11-13 07:21:31 UTC
@ Norbert Thiebaud:
I add you to the CC list of this bug report, because you have solved bug 54023 - “CRASH on launch when loading local libiconv.2.dylib” - which was very similar. Please look at this issue soon, as it makes the current master builds worthless.

@ Tor Lillqvist, Fridrich Strba:
I add you to the CC list of this bug, because you have commented on bug 54023 and similar issues, and maybe you can help Norbert, if necessary ...

Thank you all very much!
Comment 2 Roman Eisele 2012-11-13 07:26:13 UTC
LOdev 3.7.0.0.alpha0+, build ID: 88e457; pull time: 2012-11-08 04:14:44, from

http://dev-builds.libreoffice.org/daily/MacOSX-Intel@1-built_no-moz_on_10.6.8/master/2012-11-08_04.14.44/

works *correctly*; so this bug was introduced between 2012-11-08 04:14:44
and 2012-11-12 06:49:30. Hope this helps ...
Comment 3 Roman Eisele 2012-11-13 07:51:44 UTC
Created attachment 69983 [details]
Mac OS X log file for LOdev 2012-11-10, does not start



Further narrowing down the time frame:
LOdev 3.7.0.0.alpha0+ (pull time: 2012-11-10 14:19:57) for Mac OS X, from
http://dev-builds.libreoffice.org/daily/MacOSX-Intel@1-built_no-moz_on_10.6.8/master/2012-11-10_14.19.57/
does *not* start with (almost) the same error, so this problem was introduced between 2012-11-08 04:14:44 and 2012-11-10 14:19:57.

But there is a little difference: this time, the most important section of the crash report reads

“
Dyld Error Message:
  Library not loaded: /usr/local/lib/liblcms2.2.dylib
  Referenced from:    /Users/futurus/Applications/LOdev 2012-11-10/
                      LOdev 2012-11-10.app/Contents/MacOS/libvcllo.dylib
  Reason: image not found
”

So    in 2012-11-10 the problem is about loading liblcms2.2.dylib,
while in 2012-11-12 the problem is about loading liblangtag.1.dylib.

Nevertheless I guess this is the same bug, because in both instances LibreOffice attempts to load the library from 
   /usr/local/lib/
-- and this is an error in itself: at least on Mac OS X 10.6.x, by default there are NO libraries at all in this directory ...

Quoting Tor from bug 54023:
  “that /usr/local indeed is a sign that something from the *build system*
   that is peculiar to that got pipcked up […]”
Comment 4 Roman Eisele 2012-11-13 08:38:17 UTC
*** Bug 56991 has been marked as a duplicate of this bug. ***
Comment 5 Roman Eisele 2012-11-13 08:51:57 UTC
1) Confirmed by duplicate: bug 56991 - “[CRASH] Library not loaded: /usr/local/lib/liblcms2.2.dylib”.


2) The problem is not limited to the daily builds from
http://dev-builds.libreoffice.org/daily/MacOSX-Intel@1-built_no-moz_on_10.6.8/master/
because exactly the same problem occurs with the 2012-11-11 build from 
http://dev-builds.libreoffice.org/daily/MacOSX-Intel@27-OSX_10.7.0-gcc_4.2.1_llvm/master/2012-11-11_01.30.55/


3) But ... I can NO LONGER REPRODUCE the crash with the newest daily build from the latter tinderbox, which I have discovered only right now (sorry!):

LOdev 4.0.0.0.alpha0+ (Build ID: 32315e; pull time: 2012-11-13 00:32:26),
from
http://dev-builds.libreoffice.org/daily/MacOSX-Intel@27-OSX_10.7.0-gcc_4.2.1_llvm/master/2012-11-13_00.32.26/

seems to start correctly again.


Oops! So, has this problem already been fixed again? Then I am very sorry for disturbing you all!!!

But before closing this bug report again, and begging your pardon again!,
I want to be sure that this issue is really fixed.


@ Joren De Cuyper:
Can you please check if the newest master build from 
http://dev-builds.libreoffice.org/daily/MacOSX-Intel@27-OSX_10.7.0-gcc_4.2.1_llvm/master/2012-11-11_01.30.55/
does start correctly again, also on your machine?


@ Norbert Thiebaud:
Can you please check if this issue is really fixed, also on your tinderbox:
http://dev-builds.libreoffice.org/daily/MacOSX-Intel@1-built_no-moz_on_10.6.8/master/

This present bug was already some kind of reincarnation of bug 54023, so it would be great if we could make sure that this error (trying to load libraries from /usr/local/lib/) does not return anymore in the future ...
Comment 6 Jorendc 2012-11-13 11:50:38 UTC
I can confirm that the current daily (master~2012-11-13_00.32.26_LibO-Dev_4.0.0.0.alpha0_MacOS_x86_install_en-US.dmg) starts NORMALLY.
Comment 7 Roman Eisele 2012-11-13 13:08:02 UTC
(In reply to comment #6)
> I can confirm that the current daily
> (master~2012-11-13_00.32.26_LibO-Dev_4.0.0.0.alpha0_MacOS_x86_install_en-US.
> dmg) starts NORMALLY.

Thank you, Joren! OK; so I think we can set this bug to RESOLVED/WORKSFORME, at least for now; we can open it again if the bug returns.

So -- sorry for disturbing you all!

But:    Norbert, maybe Tor:
Would it be possible to make sure that this error (trying to load libraries from /usr/local/lib/, probably just because they existed on the *build* system there) does not return again in the future? That would be great -- two incarnations of this problem are enough ;-)
Comment 9 Norbert Thiebaud 2012-11-13 15:32:52 UTC
fixed by Caolan with http://cgit.freedesktop.org/libreoffice/core/commit/?id=0d08bef014415c37c9914ca1e369e2a436a31e1c

This was related to the gbuildification of libcms2 and is _not_ environmental to the tinderbox.
Comment 10 Roman Eisele 2012-11-13 17:49:32 UTC
Assigned post mortem to Caolán, to give him the honor he deserves ;-)
Verified as fixed by Joren’s and my test results.
Comment 11 tommy27 2012-11-14 13:31:53 UTC
@Roman

who's dead? the bug or the developer?  :-)
Comment 12 Roman Eisele 2012-11-14 15:07:45 UTC
(In reply to comment #11)
> who's dead? the bug or the developer?  :-)

Thank God it is the bug, because Caolán lives on and keeps fixing bugs ;-)
But you are right, my ironic usage of the “post mortem” phrase was unpleasantly ambiguous, and I should find another, less ambivalent phrase for describing
the assigment of a bug to a developer who has already fixed it ...