Download it now!
Bug 57052 - FILEOPEN particular .docx shows rotated text in text frame without rotation
Summary: FILEOPEN particular .docx shows rotated text in text frame without rotation
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-13 07:48 UTC by Rainer Bielefeld Retired
Modified: 2015-01-20 09:28 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
First mentioned attachment, saved as PDF using msWord 2007 (266.54 KB, application/pdf)
2012-11-13 09:54 UTC, sasha.libreoffice
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-11-13 07:48:00 UTC
Steps how to reproduce with "LibreOffice 3.6.3.2" German UI/ German Locale [Build-ID: 58f22d5] on German WIN7 Home Premium (64bit):

0. Download Attachment 51225 [details] of Bug 54447
1. Open sample document from LibO Start Center
   Expected: Text in text frame at the left "Conxidenxial Xesume" should be
             rotated 90°, see Attachment 56999 [details]
   Actual: no rotation

I can't test with current Master because of "Bug 57026 - FILEOPEN particular .docx shows all text frames filling complete page size and more"
Comment 1 sasha.libreoffice 2012-11-13 09:54:54 UTC
Created attachment 69991 [details]
First mentioned attachment, saved as PDF using msWord 2007
Comment 2 sasha.libreoffice 2012-11-13 10:03:24 UTC
Attachment, mentioned in step 0, contains frame with vertical text. Frame itself anchored to header of page.

reproduced in 3.5.7 and 3.6.3 on RFR 17 64 bit (text horizontal)
reproduced in 3.4.2 on Windows XP 32 bit (not text)
Comment 3 Jorendc 2013-11-03 19:30:45 UTC
Still reproducible using Mac OSX 10.9 with LibreOffice Version: 4.1.3.2
Build ID: 70feb7d99726f064edab4605a8ab840c50ec57a

Kind regards,
Joren
Comment 4 Matthew Francis 2015-01-20 09:28:15 UTC
The rotation is already fixed in 4.3.5.1, 4.4.0.2 and 4.5 master.
Not sure if the vertical alignment is quite right, but if not that should be raised as a different bug.

-> RESOLVED WORKSFORME