Download it now!
Bug 57139 - VIEWING: Bold Chinese (CJK ?) characters abnormally rendered with hardware acceleration
Summary: VIEWING: Bold Chinese (CJK ?) characters abnormally rendered with hardware ac...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.6.3.2 release
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: CJK
  Show dependency treegraph
 
Reported: 2012-11-15 03:22 UTC by Ukyoi D
Modified: 2015-12-16 08:46 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
The contradistinction of rendering with or without hardware acceleration. (80.95 KB, image/png)
2012-11-15 03:22 UTC, Ukyoi D
Details
Slide show showing Chinese, Korean and Japanese characters in bold (OpenDo) (20.38 KB, application/vnd.oasis.opendocument.presentation)
2012-12-24 14:28 UTC, webofht-libreofficebugs002
Details
Screenshots of slides showing inconsistent characters in bold (371.02 KB, application/vnd.oasis.opendocument.graphics)
2012-12-24 14:30 UTC, webofht-libreofficebugs002
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ukyoi D 2012-11-15 03:22:58 UTC
Created attachment 70096 [details]
The contradistinction of rendering with or without hardware acceleration.

Problem description: 

I'm using the newest stable Libreoffice version under Arch Linux. I found if I turn on the hardware acceleration in the settings, the bold Chinese characters will render abnormally (seems like a kind of "fake-bold", please refer to the attachment) but English characters is not affected by it. Both Chinese and English characters shows properly without acceleration.

Because I'm a Chinese, I just found the problem in Chinese characters. But I assume the problem is related to any CJK character.

Steps to reproduce:
1. (Menu Bar) Tools -> Options -> View -> set "Use hardware acceleration"
2. Input some Chinese characters and set it to bold.
3. Start slideshow.

Current behavior:
Rendering is abnormal (seems like a kind of "fake-bold").

Expected behavior:
Rendered like without hardware acceleration.

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.64 Safari/537.11
Browser: Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.64 Safari/537.11
Comment 1 webofht-libreofficebugs002 2012-12-24 14:24:53 UTC
I agree with Ukyoi D that the bold-faced characters are shown in inconsistent ways.

My operating system is Linux debian 2.6.32-5-686 #1 SMP Sun Sep 23 09:49:36 UTC 2012 i686 GNU/Linux (Linux).

In LibreOffice Impress, follow:
Tools-> Options -> LibreOffice-> 
View-> Graphics output-> 
Use hardware acceleration-> OK 
-> Slide Show -> Slide Show 

The bold-faced Chinese, Korean and Japanese characters are not displayed properly in a slide show when the hardware acceleration (HA) is used.

When HA is not used, these bold-faced characters are shown correctly.

The inconsistent problem exists in LibreOffice Version 3.6.3.2.

It also exists in LibreOffice 4.0.0.0 Beta2.

I am submitting the sample slide show and some screenshots.

Regards,
C. H. D.
Comment 2 webofht-libreofficebugs002 2012-12-24 14:28:01 UTC
Created attachment 72077 [details]
Slide show showing Chinese, Korean and Japanese characters in bold (OpenDo)
Comment 3 webofht-libreofficebugs002 2012-12-24 14:30:12 UTC
Created attachment 72078 [details]
Screenshots of slides showing inconsistent characters in bold
Comment 4 Flex Liu 2013-05-20 06:06:42 UTC
Yes, we used a fake bold for render the Bold CJK font, according fdo#47432, the fake bold improved from 3.6.4.
Comment 5 QA Administrators 2015-09-04 02:48:08 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.0.5 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-09-03
Comment 6 Buovjaga 2015-11-18 11:45:44 UTC
For me, it looks ok now both ways.

Please retest.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: b216cc1b8096eb60c27f67e8c27b7cd756c75e38
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-11-12_00:06:20
Locale: fi-FI (fi_FI)
Comment 7 Ukyoi D 2015-12-16 07:55:26 UTC
This bug seems to be fixed now. Sorry for the delaying of changing the status.
Comment 8 Buovjaga 2015-12-16 08:46:43 UTC
Thanks, setting to WFM.